ΘΕΜΑ Γ
Το Υπουργείο Παιδείας παρέχει μέσω του διαδικτύου μια συλλογή από  εκπαιδευτικά βίντεο. Ο αριθμός των επισκέψεων που δέχεται κάθε ένα βίντεο  καταγράφεται από ειδικό λογισμικό. Τα βίντεο διακρίνονται σε τρείς κατηγορίες  ανάλογα με την επισκεψιμότητά τους, σύμφωνα με τον παρακάτω πίνακα: 

ΚΑΤΗΓΟΡΙΕΣ ΕΠΙΣΚΕΨΙΜΟΤΗΤΑΣ
Όνομα  Αριθμός Επισκέψεων
Χαμηλή  
Μεσαία 
Υψηλή 
από 1 έως και 100 
από 101 έως και 1000 
πάνω από 1000

 
Τα βίντεο με μηδενικές επισκέψεις δεν κατατάσσονται σε καμία κατηγορία.
Να αναπτύξετε πρόγραμμα το οποίο: 

Γ1. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. 
Μονάδες 2 
Γ2. Να διαβάζει επαναληπτικά τον τίτλο κάθε βίντεο και τον αριθμό των  επισκέψεων που δέχτηκε. Η είσοδος των δεδομένων να τερματίζεται, όταν ως τίτλος βίντεο δοθεί η λέξη «ΤΕΛΟΣ». (μονάδες 3) Να γίνεται έλεγχος εγκυρότητας ώστε ο αριθμός των επισκέψεων να μην  είναι αρνητικός. (μονάδες 2) 
Μονάδες 5 

Γ3. Να βρίσκει και να εμφανίζει τον τίτλο του βίντεο με τον μεγαλύτερο  αριθμό επισκέψεων. Να θεωρήσετε ότι είναι μοναδικό. 
Μονάδες 4 

Γ4. Να υπολογίζει για καθεμία από τις τρεις κατηγορίες επισκεψιμότητας το  πλήθος των βίντεο που καταχωρίστηκαν σε αυτή. Να εμφανίζει για κάθε  κατηγορία: 
– το όνομά της και  
– το πλήθος των βίντεο που περιλαμβάνει. 
Μονάδες 6 

Γ5. Να βρίσκει και να εμφανίζει το όνομα της κατηγορίας επισκεψιμότητας  στην οποία καταχωρίστηκαν τα περισσότερα βίντεο. Να θεωρήσετε ότι  είναι μοναδική. 
Μονάδες 3 
Σημείωση 
Το πλήθος των βίντεο δεν είναι γνωστό. 

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ θέμαΓ2019
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: επισκεψεις, πλ_χαμηλη, πλ_μεσαια, πλ_υψηλη, μεγιστη, μαξ
  ΧΑΡΑΚΤΗΡΕΣ: τιτλος, τιτλος_μαξ
ΑΡΧΗ
  μαξ <- -1
  ΔΙΑΒΑΣΕ τιτλος
  πλ_χαμηλη <- 0
  πλ_μεσαια <- 0
  πλ_υψηλη <- 0
  πλ0 <- 0
  ΟΣΟ τιτλος <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
! Γ2
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ επισκεψεις
    ΜΕΧΡΙΣ_ΟΤΟΥ επισκεψεις >= 0
! Γ3
    ΑΝ επισκεψεις > μαξ ΤΟΤΕ
      μαξ <- επισκεψεις
      τιτλος_μαξ <- τιτλος
    ΤΕΛΟΣ_ΑΝ
! Γ4
    ΑΝ επισκεψεις >= 1 ΚΑΙ επισκεψεις <= 100 ΤΟΤΕ
      πλ_χαμηλη <- πλ_χαμηλη + 1
    ΑΛΛΙΩΣ_ΑΝ επισκεψεις <= 1000 ΤΟΤΕ
      πλ_μεσαια <- πλ_μεσαια + 1
    ΑΛΛΙΩΣ
      πλ_υψηλη <- πλ_υψηλη + 1
    ΤΕΛΟΣ_ΑΝ

    ΔΙΑΒΑΣΕ τιτλος
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'κατ1:', πλ_χαμηλη
  ΓΡΑΨΕ 'κατ2:', πλ_μεσαια
  ΓΡΑΨΕ 'κατ3:', πλ_υψηλη
! Γ5
  μεγιστη <- πλ_χαμηλη
  τιτλος_μαξ <- 'Χαμήλη'

  ΑΝ πλ_μεσαια > μεγιστη ΤΟΤΕ
    μεγιστη <- πλ_μεσαια
    τιτλος_μαξ <- 'Μεσαία'
  ΤΕΛΟΣ_ΑΝ

  ΑΝ πλ_υψηλη > μεγιστη ΤΟΤΕ
    μεγιστη <- πλ_υψηλη
    τιτλος_μαξ <- 'Υψηλή'
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ τιτλος_μαξ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This