Επιλογή Σελίδας

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 6

!6. Το Υπουργείο Οικονομικών φορολογεί τους Ελεύθερους Επαγγελματίες
! σύμφωνα με τον παρακάτω πίνακα:
! 1. Από 1€ μέχρι 20.000€ – 22%
! 2. Από 20.001€ μέχρι 30.000€ – 29% (για τα επόμενα 10000€)
! 3. Από 30.001€ μέχρι 40.000€ – 37% (για τα επόμενα 10000€)
! 4. Από 40.001€ και άνω _ 45% (για όλα τα επόμενα €)

!Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ»,
!το οποίο να διαβάζει το εισόδημα ενός ελεύθερου επαγγελματία
!και στη συνέχεια να υπολογίζει και να εμφανίζει τον φόρο που του αναλογεί.
!Ο υπολογισμός φόρου γίνεται κλιμακωτά, σύμφωνα με τον παραπάνω πίνακα.

ΠΡΟΓΡΑΜΜΑ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: εισ, φόρος
ΑΡΧΗ
ΔΙΑΒΑΣΕ εισ

! υπολογισμός φόρου κλιμακωτά
Αν εισ <= 20000 τότε
φόρος <– εισ * 0,22
αλλιώςαν εισ <= 30000 τότε
φόρος <– 20000 * 0,22 + (εισ – 20000) * 0,29
αλλιώς
αν εισ <= 40000 τότε
φόρος <– 20000 * 0,22 + 10000 * 0,29 + (εισ – 30000) * 0,37
αλλιώς
φόρος <– 20000 * 0,22 + 10000 * 0,29 + 10000 * 0,37 + (εισ – 40000) * 0,45
τέλος_αν

Γράψε φόρος

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 4

! Παράρτημα Α – Οδηγίες Μαθητή (β έκδοση) – 2.5 Επιλογή
! 4. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το όνομα ενός υπαλλήλου, τις ώρες
! εργασίας και το ωρομίσθιο του.
! Οι κρατήσεις που γίνονται στον υπάλληλο είναι 15%, αν ο μισθός του είναι μέχρι 1.000?,
! διαφορετικά είναι 20%.
! Σε περίπτωση που ο υπάλληλος έχει λιγότερες από 15 ώρες εργασίας τότε
! οι παραπάνω κρατήσεις μειώνονται κατά 2%.
! Υπόδειξη: Ο μισθός κάθε υπαλλήλου υπολογίζεται από τον τύπο:
! Ώρες x Ωρομίσθιο – Κρατήσεις

!Και οι κρατήσεις από τον τύπο:
!Κρατήσεις=(Ώρες x Ωρομίσθιο) x Ποσοστό/100

ΠΡΟΓΡΑΜΜΑ par_a_2_5_epilogi_4
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ω, ωρ, μισθός, κρατήσεις
ΧΑΡΑΚΤΗΡΕΣ: ον
ΑΡΧΗ
ΔΙΑΒΑΣΕ ον, ω, ωρ

μισθός <-- ω * ωρ Αν ω > 15 τότε
Αν μισθός > 1000 τότε
κρατήσεις <-- μισθός * 0.20 αλλιώς κρατήσεις <-- μισθός * 0.15 Τέλος_αν αλλιώς Αν μισθός > 1000 τότε
κρατήσεις <– μισθός * 0.18
αλλιώς
κρατήσεις <– μισθός * 0.13
Τέλοςαν
Τέλος
αν

! λύση και λογικές προτάσεις και απλές επιλογές
! Αν ω > 15 και μισθός > 1000 τότε
! κρατήσεις <-- μισθός * 0.20 ! τέλος_αν ! αν ω > 15 και μισθός < 1000 τότε
! κρατήσεις <-- μισθός * 0.15 ! τέλος_αν ! αν ω < 15 και μισθός > 1000 τότε
! κρατήσεις <– μισθός * 0.18
! τέλοςαν
! αν ω < 15 και μισθός < 1000 τότε
! κρατήσεις <– μισθός * 0.13
! τέλος
αν

! λύση και λογικές προτάσεις και πολλαπλή επιλογή
! Αν ω > 15 και μισθός > 1000 τότε
! κρατήσεις <-- μισθός * 0.20 ! αλλιώς_αν ω > 15 και μισθός < 1000 τότε
! κρατήσεις <-- μισθός * 0.15 ! αλλιώς_αν ω < 15 και μισθός > 1000 τότε
! κρατήσεις <– μισθός * 0.18
! αλλιώςαν ω < 15 και μισθός < 1000 τότε
! κρατήσεις <– μισθός * 0.13
! τέλος
αν

μισθός <– μίσθος – κρατήσεις
γράψε ον, μισθός

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παράρτημα Α – 2.5 Επιλογή – Άσκηση 3

Παράρτημα Α – Οδηγίες Μαθητή (β έκδοση) – 2.5 Επιλογή
3. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει από το πληκτρολόγιο τρεις διαφορετικούς ακέραιους αριθμούς και στη συνέχεια να τυπώνει τον αριθμό που η αξία του είναι ανάμεσα στον μεγαλύτερο και στον μικρότερο από αυτούς (δηλαδή, αν δοθούν οι αριθμοί 107,53,42 τότε θα εμφανιστεί ο 53, διότι 107>53>42 ή 42<53<107).
(περισσότερα…)

Θέμα A, Ερώτημα 1, 2017, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Η έκφραση ΟΧΙ(Κ=10 ΚΑΙ Χ>7) είναι ισοδύναμη με την έκφραση (Κ<>10 Ή Χ<=7).
  2. Η χρησιμοποίηση του διερμηνευτή για τη μετάφραση ενός προγράμματος έχει ως αποτέλεσμα την ταχύτερη εκτέλεσή του.
  3. Οι εντολές στη δομή επανάληψης «ΓΙΑ» εκτελούνται τουλάχιστον μία φορά.
  4. Πολύ συχνά οι εντολές που έχουν γραφτεί με εμφωλευμένα ΑΝ μπορούν να γραφτούν πιο απλά χρησιμοποιώντας σύνθετες εκφράσεις ή την εντολή επιλογής ΑΝ… ΤΟΤΕ… ΑΛΛΙΩΣ_ΑΝ.
  5. Κάθε υποπρόγραμμα μπορεί να σχεδιαστεί, να αναπτυχθεί και να συντηρηθεί αυτόνομα.

Μονάδες 10

Θέμα A, Ερώτημα 3, 2017, Ημερήσια

i <– 0
k <–  12
Όσο i<=k επανάλαβε
         i <– i+2
         k <– k-1
         Γράψε i,k
Τέλος_επανάληψης
Να μεταφέρετε στο τετράδιό σας τον παρακάτω πίνακα και να συμπληρώσετε τις τιμές των μεταβλητών που θα εμφανίζει το παραπάνω απόσπασμα αλγορίθμου σε κάθε επανάληψη:

Οθόνη (εμφάνιση των i και k)

Επανάληψη 1
Επανάληψη 2

Μονάδες 10

Θέμα A, Ερώτημα 4, 2017, Ημερήσια

Α4. Έστω ότι έχουμε το παρακάτω απόσπασμα αλγορίθμου:
S <– 0
Για i από 5 μέχρι 20 με βήμα 3
Διάβασε Χ
     S <– S + X
Τέλοςεπανάληψης
Να ξαναγράψετε το παραπάνω απόσπασμα αλγορίθμου χρησιμοποιώντας αντί για την εντολή Για… Τέλος
επανάληψης:
α) την εντολή Όσο…Τέλοςεπανάληψης
(μονάδες 5)
β) την εντολή Αρχή
επανάληψης…Μέχρις_ότου
(μονάδες 5)
Μονάδες 10

Θέμα Β, 2017, Ημερήσια

ΘΕΜΑ Β
Β1. Δίνεται το παρακάτω απόσπασμα αλγορίθμου:
i<– …(1)
Όσο i≤ …(2) επανάλαβε
Αν i …(3) <> …(4) τότε
Γράψε i
Τέλοςαν
i <– i +  …(5)
Τέλος
επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του παραπάνω αποσπάσματος, και δίπλα σε κάθε αριθμό τι πρέπει να συμπληρωθεί, ώστε με την εκτέλεσή του να εμφανίζονται οι τιμές:
4, 8, 16, 20, 28, 32, 40
Μονάδες 10
Β2. Το ακόλουθο πρόγραμμα έχει σκοπό να διαβάζει 10 θετικούς αριθμούς και να υπολογίζει και να εμφανίζει το γινόμενο όσων από αυτούς είναι πολλαπλάσιοι και του 3 και του 5 (συγχρόνως). Στο πρόγραμμα, όμως, υπάρχουν λάθη.
α) Να εντοπίσετε τα λάθη αυτά και στο τετράδιό σας να γράψετε τον αριθμό της γραμμής που βρίσκεται το λάθος και τον χαρακτηρισμό του (συντακτικό ή λογικό).
β) Στη συνέχεια να γράψετε το σωστό πρόγραμμα διορθώνοντας τα λάθη που εντοπίσατε.
1. Πρόγραμμα Αριθμοί
2. Μεταβλητές
3.    Πραγματικές: Χ
4.    Ακέραιες: Ρ, i
5. Αρχή
6. Ρ <– 0
7. Για i από 1 μέχρι 10
8.      Διάβασε Χ
9.     Αν Χ MOD 3 = 0 Ή MOD 5 = 0 τότε
10         Ρ <– Ρ * Χ
11.    Τέλοςεπανάληψης
12. Τέλος
επανάληψης
13. Γράψε Ρ
14 Τέλος_προγράμματος
Σημείωση: Θεωρείστε ότι κατά την εκτέλεση του προγράμματος θα δοθεί τουλάχιστον ένας τέτοιος αριθμός.
Μονάδες 10

Θέμα Γ, 2017, Ημερήσια

ΘΕΜΑ Γ
Στο πλαίσιο ενός τοπικού σχολικού πρωταθλήματος βόλεϊ συμμετέχουν 5 σχολεία, αριθμημένα από το 1 έως το 5. Κάθε σχολείο παίζει μία φορά με όλα τα υπόλοιπα. Άρα θα πραγματοποιηθούν συνολικά 10 αγώνες. Νικητής ενός αγώνα είναι το σχολείο που έχει κερδίσει 3 σετ. Ο νικητής παίρνει 2 βαθμούς και ο ηττημένος 1 βαθμό.
Κάθε αγώνας προσδιορίζεται από τα σχολεία που παίζουν μεταξύ τους και το αποτέλεσμα του αγώνα σε σετ. Για παράδειγμα, η σειρά των στοιχείων: 4, 5, 1, 3 σημαίνει ότι το σχολείο 4 έπαιξε με το σχολείο 5 και έχασε τον αγώνα με 1 σετ υπέρ και 3 κατά. Αυτό αντίστοιχα σημαίνει ότι το σχολείο 5 κέρδισε τον αγώνα με το σχολείο 4 με 3 σετ υπέρ και 1 σετ κατά.
Τα δεδομένα των αγώνων αποθηκεύονται σε έναν δισδιάστατο πίνακα Α[5,3], όπου κάθε γραμμή αντιστοιχεί σε ένα σχολείο. Η τελική μορφή του πίνακα Α θα περιέχει για κάθε σχολείο, στην πρώτη (1η) στήλη τη βαθμολογία του (το άθροισμα των βαθμών του), στη δεύτερη (2η) το άθροισμα των σετ υπέρ και στην τρίτη (3η) το άθροισμα των σετ κατά, από όλους τους αγώνες.
Να κατασκευάσετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
Γ1. α) Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 2)
β) Να διαβάζει τα ονόματα των 5 σχολείων και να τα καταχωρίζει στον πίνακα ΟΝ [5]. Η σειρά των σχολείων καθορίζει την αρίθμησή τους (1 έως 5). (μονάδες 2)
γ) Να αρχικοποιεί τον πίνακα Α[5,3]. (μονάδες 2)
Μονάδες 6
Γ2. Να διαβάζει για κάθε αγώνα τη σειρά των 4 στοιχείων που τον προσδιορίζουν και να ενημερώνει τον πίνακα Α και για τα δύο σχολεία όπως περιγράφεται παραπάνω.
Μονάδες 6
Γ3. Να κατατάσσει τα σχολεία σε φθίνουσα σειρά ανάλογα με τη βαθμολογία τους και σε περίπτωση ισοβαθμίας να προηγείται το σχολείο με τα περισσότερα σετ υπέρ.
Μονάδες 6
Γ4. Να εμφανίζει τα ονόματα των σχολείων, τη βαθμολογία τους, το άθροισμα των σετ υπέρ και το άθροισμα των σετ κατά, με βάση τη σειρά κατάταξής τους.
Μονάδες 2
Σημείωση: Θεωρείστε ότι δεν υπάρχει περίπτωση δύο σχολεία να έχουν και την ίδια βαθμολογία και τον ίδιο αριθμό σετ υπέρ.

Θέμα Δ, 2017, Ημερήσια

ΘΕΜΑ Δ
Σε ένα σεμινάριο διάρκειας 6 μηνών, τηρούνται απουσίες ανά μήνα για κάθε συμμετέχοντα. Στο σεμινάριο συμμετέχουν 50 επιμορφούμενοι και ο καθένας έχει ένα μοναδικό αλφαριθμητικό κωδικό, που αποθηκεύεται στον πίνακα ΚΩΔ[50]. Οι απουσίες κάθε συμμετέχοντα ανά μήνα σεμιναρίου αποθηκεύονται σε δισδιάστατο πίνακα απουσιών ΑΠ[50,6]. Η γραμματεία τηρεί το σύνολο των απουσιών για τα δύο τρίμηνα του εξαμήνου σε πίνακα ΑΠΤΡ[50,2], όπου η πρώτη στήλη προσδιορίζει το πρώτο τρίμηνο και η δεύτερη το δεύτερο τρίμηνο για κάθε συμμετέχοντα.
Να κατασκευάσετε πρόγραμμα σε ΓΛΩΣΣΑ αποτελούμενο από υποπρογράμματα ως εξής:
Δ1. Διαδικασία ΕΙΣ, που διαβάζει τον κωδικό του κάθε επιμορφούμενου, τις απουσίες του ανά μήνα σεμιναρίου και ενημερώνει τον πίνακα ΚΩΔ και τον πίνακα ΑΠ κατάλληλα (θεωρείστε ότι τα δεδομένα εισάγονται σωστά). Μονάδες 2
Δ2. Συνάρτηση ΑΝΑΖ, που δέχεται τον κωδικό ενός επιμορφούμενου και τον πίνακα των κωδικών ΚΩΔ και επιστρέφει τον αριθμό της γραμμής που βρίσκεται ο κωδικός που αναζητείται. Αν ο κωδικός δεν βρεθεί, επιστρέφει 0. Μονάδες 4
Δ3. Συνάρτηση ΣΥΝΑΠ, που υπολογίζει το σύνολο απουσιών για έναν επιμορφούμενο σε ένα τρίμηνο. Η συνάρτηση δέχεται τον αριθμό της γραμμής που προσδιορίζει τον επιμορφούμενο στον πίνακα ΑΠ, τον πίνακα των απουσιών και τον αριθμό του πρώτου μήνα του τριμήνου (για παράδειγμα, 1 για το πρώτο τρίμηνο, 4 για το δεύτερο τρίμηνο) και επιστρέφει το σύνολο των απουσιών του τριμήνου.
Μονάδες 3
Δ4. Κύριο πρόγραμμα το οποίο:
α) περιέχει τμήμα δηλώσεων. (μονάδα 1)
β) καλεί τη διαδικασία ΕΙΣ για είσοδο δεδομένων. (μονάδα 1)
γ) για κάθε επιμορφούμενο υπολογίζει το σύνολο των απουσιών των δύο
τριμήνων καλώντας τη συνάρτηση ΣΥΝΑΠ και ενημερώνει τον πίνακα
ΑΠΤΡ. (μονάδες 3)
δ) διαβάζει επαναληπτικά έναν κωδικό. Για τον συγκεκριμένο κωδικό καλείται η συνάρτηση ΑΝΑΖ. Αν ο κωδικός αντιστοιχεί σε επιμορφούμενο, να εμφανίζει κατάλληλο μήνυμα δυνατότητας ή μη συμμετοχής του στις εξετάσεις. Στις εξετάσεις δικαιούνται συμμετοχής οι επιμορφούμενοι που έχουν λιγότερες από 10 απουσίες σε καθένα από τα δύο τρίμηνα. Αν ο κωδικός δεν βρεθεί, εμφανίζει μήνυμα «ΔΕΝ ΒΡΕΘΗΚΕ Ο ΚΩΔΙΚΟΣ». Η διαδικασία επαναλαμβάνεται μέχρι να δοθεί ως κωδικός η λέξη ΤΕΛΟΣ. (μονάδες 6)
Μονάδες 11

Άσκηση 14, Παράρτημα Α, ΙΕΠ, Επαναλήψεις, Επιβίβαση – Αποβίβαση Ασανσέρ

Σ’ ένα ασανσέρ επιτρέπεται να επιβιβασθούν 8 άτομα και το μέγιστο επιτρεπτό ωφέλιμο βάρος στο ασανσέρ είναι 900 κιλά. Το ασανσέρ ξεκινά όταν γεμίσει (όταν το σύνολο των ατόμων δεν ξεπερνά τα 8 άτομα ή αν το συνολικό βάρος δεν υπερβαίνει τα 900 κιλά) ή όταν δεν υπάρχει άλλο άτομο για να επιβιβασθεί στον όροφο που έχει σταματήσει. Το ασανσέρ κάνει συνολικά 8 στάσεις. Σε κάθε στάση, εκτός της τελευταίας, το πρόγραμμα εμφανίζει το μήνυμα “Υπάρχει άτομο να εισέλθει; (ΝΑΙ ή ΟΧΙ)”. Αν η απάντηση είναι “ΝΑΙ” εισάγεται το βάρος του ατόμου και έτσι σηματοδοτείται η επιβίβασή του στο ασανσέρ. Η παραπάνω διαδικασία επαναλαμβάνεται μέχρι να δοθεί η απάντηση “ΟΧΙ” και να σταματήσει η επιβίβαση.
Επίσης σε κάθε στάση, εκτός από την πρώτη, το πρόγραμμα εμφανίζει το μήνυμα “Υπάρχει άτομο να εξέλθει; (ΝΑΙ ή ΟΧΙ)”, αν η απάντηση είναι “ΝΑΙ” εισάγεται το βάρος του ατόμου και έτσι* σηματοδοτείται η επιβίβαση αποβίβαση στο ασανσέρ. Η πα­ραπάνω διαδικασία επαναλαμβάνεται μέχρι να δοθεί η απάντηση “ΟΧΙ”.
Να γραφεί πρόγραμμα που να περιγράφει την παραπάνω λειτουργία του ασανσέρ και στο τέλος να τυπώνει το σύνολο των ατόμων που εισείλθαν στο ασανσέρ στη 1η στάση και το σύνολο των ατόμων που αποβιβάστηκαν στην 8η στάση.
Παρατήρηση*: Απαραίτητη προσθήκη στην αρχική άσκηση, για να λυθεί χωρίς τη βοήθεια πινάκων.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΑΣΚ14_ΠΑΡ_Α_ΙΕΠ_2017
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: στάση, άτομα , Επιβαίνοντες1ης, βάρος_ολ, βάρος_ατ 
  ΛΟΓΙΚΕΣ: επιβιβάζονται, αποβιβάζονται
  ΧΑΡΑΚΤΗΡΕΣ: απάντηση     

ΑΡΧΗ 
  άτομα <-- 0
  βάρος_ολ <-- 0

  ΓΙΑ στάση ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ 'ΣΤΑΣΗ ', στάση

    ΓΡΑΨΕ 'ΕΠΙΒΙΒΑΣΗ'
    επιβιβάζονται <-- ΑΛΗΘΗΣ
    ΟΣΟ επιβιβάζονται = ΑΛΗΘΗΣ ΚΑΙ βάρος_ολ < 900 ΚΑΙ άτομα < 8 ΚΑΙ στάση <> 8 ΕΠΑΝΑΛΑΒΕ
      
      ΓΡΑΨΕ 'Υπάρχει άτομο να εισέλθει; (ΝΑΙ ή ΟΧΙ)'
      ΔΙΑΒΑΣΕ απάντηση
      ΑΝ απάντηση = 'ΝΑΙ' ΤΟΤΕ
        ΓΡΑΨΕ 'ΒΑΡΟΣ: '
        ΔΙΑΒΑΣΕ βάρος_ατ
        ΑΝ βάρος_ολ + βαρος_ατ <=900 ΤΟΤΕ
          βάρος_ολ <-- βάρος_ολ + βάρος_ατ
          άτομα <-- άτομα + 1
        ΑΛΛΙΩΣ   
          ΓΡΑΨΕ 'ΑΔΥΝΑΤΟ - ΥΠΕΡΒΑΣΗ ΒΑΡΟΥΣ'
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ_ΑΝ απάντηση = 'ΟΧΙ' ΤΟΤΕ
        επιβιβάζονται <-- ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ στάση = 1 ΤΟΤΕ
      Επιβαίνοντες1ης <-- άτομα
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'ΑΠΟΒΙΒΑΣΗ' 
    αποβιβάζονται <-- ΑΛΗΘΗΣ
    ΟΣΟ αποβιβάζονται = ΑΛΗΘΗΣ ΚΑΙ άτομα > 0 ΚΑΙ στάση <> 1 ΕΠΑΝΑΛΑΒΕ

      ΓΡΑΨΕ 'Υπάρχει άτομο να εξέλθει; (ΝΑΙ ή ΟΧΙ)'
      ΔΙΑΒΑΣΕ απάντηση
      ΑΝ απάντηση = 'ΝΑΙ' ΤΟΤΕ
        ΓΡΑΨΕ 'ΒΑΡΟΣ: '
        ΔΙΑΒΑΣΕ βάρος_ατ         ! Δεν περιλαμβάνεται στην εκφώνηση, βλ.Παρατήρηση
        βάρος_ολ <-- βάρος_ολ - βάρος_ατ
        άτομα <-- ατομα - 1
      ΑΛΛΙΩΣ_ΑΝ απάντηση = 'ΟΧΙ' ΤΟΤΕ
        αποβιβάζονται <-- ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Εισήλθαν στην 1η στάση', Επιβαίνοντες1ης
  ΓΡΑΨΕ 'Εξήλθαν στην 8η στάση', άτομα
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

16, Παράρτημα Β, ΙΕΠ, Άσκηση εμπέδωσης στους πίνακες, ΕΠΥ, 27ος ΠΔΠ (2015), Γ’ Φάση (Θέμα 1ο)

Λέμε ότι δύο φυσικοί αριθμοί είναι στην ίδια “παρέα” όταν έχουν το ίδιο πλήθος άσων (1) στην δυαδική τους αναπαράσταση. Για παράδειγμα, το 5 και το 17 είναι στην ίδια παρέα γιατί 5 = 101(2) και 17 = 10001(2), άρα και οι δύο αυτοί αριθμοί έχουν δύο άσους στη δυαδική τους αναπαράσταση. Αντίθετα, το 1.

Πρόβλημα:

Να γραφεί ένα πρόγραμμα σε Γλώσσα, το οποίο θα διαβάζει μία ακολουθία Ν αριθμών και στη συνέχεια θα βρίσκει και θα εμφανίζει το πλήθος των μελών της μεγαλύτερης παρέας που μπορεί να σχηματιστεί από όρους της ακολουθίας. Η ακολουθία ενδέχεται να περιέχει όρους που είναι ίσοι και στην περίπτωση αυτή, θα πρέπει να συμπεριλάβετε όλους τους ίσους όρους, στην ίδια φυσικά παρέα.

ΛΥΣΗ (περισσότερα…)