Α3.
Δίνεται το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ:

ΔΙΑΒΑΣΕ α 
β <- 1 
OΣΟ α<=5 EΠΑΝΑΛΑΒΕ 
β <- β + α  
ΔΙΑΒΑΣΕ α 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ </code class="language-javascript">

Να μετατραπεί σε ισοδύναμο με χρήση της εντολής ΜΕΧΡΙΣ_ΟΤΟΥ.
Μονάδες 7

Λύση

ΔΙΑΒΑΣΕ α 
β <- 1 
ΑΝ α<=5 ΤΟΤΕ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
β <- β + α  
ΔΙΑΒΑΣΕ α 
ΜΕΧΡΙΣ_ΟΤΟΥ α > 5
ΤΕΛΟΣ_ΑΝ </code class="language-javascript">
Share This