Α4.
Δίνεται το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ:

ΠΡΟΓΡΑΜΜΑ Α4 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: χ 
ΑΡΧΗ 
ΓΡΑΨΕ ‘Δώσε μονοψήφιο αριθμό: ’ 
ΔΙΑΒΑΣΕ χ 
ΑΝ (χ=2) Ή (χ=4) Ή (χ=6) Ή (χ=8) ΤΟΤΕ 
ΓΡΑΨΕ ‘Άρτιος’ 
ΑΛΛΙΩΣ_ΑΝ (χ=1) Ή (χ=3) Ή (χ=5) Ή (χ=7) Ή (χ=9) ΤΟΤΕ 
ΓΡΑΨΕ ‘Περιττός’ 
ΑΛΛΙΩΣ_ΑΝ χ=0 ΤΟΤΕ 
ΓΡΑΨΕ ‘Μηδέν’ 
ΑΛΛΙΩΣ 
ΓΡΑΨΕ ‘Ο αριθμός δεν είναι μονοψήφιος…’ 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ</code class="language-javascript">

Να μετατραπεί σε ισοδύναμο με χρήση της εντολής πολλαπλής επιλογής ΕΠΙΛΕΞΕ.
Μονάδες 6

Λύση

ΠΡΟΓΡΑΜΜΑ Α4 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: χ 
ΑΡΧΗ 
ΓΡΑΨΕ ‘Δώσε μονοψήφιο αριθμό: ’ 
ΔΙΑΒΑΣΕ χ 
ΕΠΙΛΕΞΕ Χ
ΠΕΡΙΠΤΩΣΗ 2,4,6,8
ΓΡΑΨΕ ‘Άρτιος’ 
ΠΕΡΙΠΤΩΣΗ 1,3,5,7,9 
ΓΡΑΨΕ ‘Περιττός’ 
ΠΕΡΙΠΤΩΣΗ 0
ΓΡΑΨΕ ‘Μηδέν’ 
ΠΕΡΙΠΤΩΣΗ ΑΛΛΙΩΣ 
ΓΡΑΨΕ ‘Ο αριθμός δεν είναι μονοψήφιος…’ 
ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ</code class="language-javascript">
Share This