Β1. Να γράψετε υποπρόγραμμα, το οποίο να διαβάζει 1000 ακέραιους αριθμούς με έλεγχο εγκυρότητας, ώστε να είναι θετικοί. Το υποπρόγραμμα να επιστρέφει το πλήθος των αριθμών που είναι πολλαπλάσια του 3 και το άθροισμα των τριψήφιων.
Μονάδες 12
ΛΥΣΗ


ΔΙΑΔΙΚΑΣΙΑ Β1(π3, αθ)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: αρ, ι, π3, αθ
ΑΡΧΗ
π3 <- 0
αθ <- 0
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 1000
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ αρ
ΜΕΧΡΙΣ_ΟΤΟΥ αρ > 0 

ΑΝ αρ mod = 3 TOTE
π3 <- π3 + 1
ΤΕΛΟΣ_ΑΝ
ΑΝ αρ >= 100 ΚΑΙ αρ <= 999 ΤΟΤΕ
αθ <- αθ + αρ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ</code class="language-javascript">

Εναλλακτικά μπορεί να λυθεί και με χρήση μονοδιάστατου πίνακα 1000 θέσεων.

Share This