Επιλογή Σελίδας

Θέμα A, Ερώτημα 1, 2014, Ημερήσια

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΣΤΟ, αν η πρόταση είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη.

  1. Οι εκφράσεις διαμορφώνονται από τους τελεστέους και τους τελεστές. (μονάδες 2)
  2. Σκοπός της ταξινόμησης είναι να διευκολυνθεί στη συνέχεια η αναζήτηση των στοιχείων του ταξινομημένου πίνακα. (μονάδες 2)
  3. To εκτελέσιμο πρόγραμμα δημιουργείται ακόμα και στην περίπτωση που το αρχικό πρόγραμμα περιέχει λογικά, αλλά όχι συντακτικά λάθη. (μονάδες 2)
  4. Οι λογικές τιμές είναι οι εξής: ΟΧΙ, ΚΑΙ, Ή. (μονάδες 2)
  5. Μεταξύ των εντολών του σώματος μιας συνάρτησης πρέπει υποχρεωτικά να υπάρχει τουλάχιστον μία εντολή εκχώρησης τιμής στο όνομα της συνάρτησης. (μονάδες 2)

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα A, Ερώτημα 4, 2013, Επαναληπτικές, Ημερήσια

Πρώτος ονομάζεται ένας φυσικός αριθμός, όταν έχει ακριβώς δύο διαιρέτες: τον εαυτό του και τη μονάδα. Ο παρακάτω αλγόριθμος γράφτηκε, έτσι ώστε να εμφανίζει τους πρώτους αριθμούς από το 2 μέχρι και το 100.

ΑΛΓΟΡΙΘΜΟΣ πρώτοι
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
Μ <i
ΓΙΑ j ΑΠΟ 0 ΜΕΧΡΙ i
ΑΝ i / j = 0 ΤΟΤΕ
Μ <- Μ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Μ < 3 ΤΟΤΕ ΕΜΦΑΝΙΣΕ i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ πρώτοι
Ο παραπάνω αλγόριθμος έχει λάθη. Να τον γράψετε στο τετράδιό σας, κάνοντας τις απαραίτητες διορθώσεις, ώστε να λειτουργεί σωστά, χωρίς την προσθήκη νέων εντολών.

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια

Θέμα A, Ερώτημα 3, 2012, Επαναληπτικές, Ημερήσια

Ο παρακάτω αλγόριθμος προτάθηκε για να ελέγχει και να εκτυπώνει, αν ένας μη αρνητικός ακέραιος αριθμός είναι μονοψήφιος, διψήφιος ή τριψήφιος.

Στην περίπτωση που δοθεί αριθμός αρνητικός ή με περισσότερα από 3 ψηφία ο αλγόριθμος πρέπει να εμφανίζει το μήνυμα «Λάθος Δεδομένα».

Αλγόριθμος Ψηφία
Διάβασε x
Αν x >= 0 και x < 10 τότε
εμφάνισε ΄Μονοψήφιος΄
Αλλιώς_αν
x < 100 τότε
εμφάνισε ΄Διψήφιος΄
Αλλιώς_αν x < 1000 τότε
εμφάνισε
΄Τριψήφιος΄
Αλλιώς
εμφάνισε ΄Λάθος Δεδομένα΄
Τέλος_αν
Τέλος Ψηφία

Ο παραπάνω αλγόριθμος έχει λάθος. Δώστε ένα παράδειγμα εισόδου που θα καταδείξει το λάθος που υπάρχει στον αλγόριθμο (Μονάδες 3).
Στη συνέχεια να γράψετε τον αλγόριθμο στο τετράδιο σας κάνοντας τις απαραίτητες διορθώσεις, έτσι ώστε να λειτουργεί σωστά (Μονάδες 7).

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Ερώτημα 3, Θέμα Α. 2009, Μαΐου-Ιουνίου, Ημερήσια

1.   Η  κατανόηση  ενός προβλήματος αποτελεί συνάρτηση δύο παραγόντων. Να τους αναφέρετε.
Μονάδες 4
2.  α. Πότε εμφανίζονται τα συντακτικά λάθη ενός προγράμματος και πότε τα λογικά;
Μονάδες 2
β.    Δίνονται   οι   παρακάτω   λανθασμένες   εντολές   για τον υπολογισμό του μέσου όρου δύο αριθμών:

  1. Γ<- Α+Β/2
  2. Γ<- (Α+Β/2
  3. Γ<- (Α+Β/2)
  4. Γ<- (Α+Β):2

Να γράψετε στο τετράδιό σας τον αριθμό της κάθε εντολής (1, 2, 3, 4) και δίπλα τη λέξη συντακτικό ή τη λέξη λογικό, ανάλογα με το είδος του λάθους.
Μονάδες 4

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 1, 2002, Επαναληπτικές

Να γράψετε στο τετράδιό σας τον αριθμό κάθε πρότασης και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη.

  1. Η τιμή μιας μεταβλητής δεν μπορεί να αλλάξει κατά τη διάρκεια εκτέλεσης ενός αλγόριθμου.
  2. Με τον όρο δεδομένο αναφέρεται οποιοδήποτε γνωσιακό στοιχείο προέρχεται από επεξεργασία δεδομένων.
  3. Σκοπός της συγχώνευσης δύο ταξινομημένων πινάκων είναι η δημιουργία ενός τρίτου ταξινομημένου πίνακα, που περιέχει τα στοιχεία των δύο πινάκων.
  4. Τα λογικά λάθη είναι συνήθως λάθη σχεδιασμού και δεν προκαλούν τη διακοπή της εκτέλεσης του προγράμματος.
  5. Σε ένα μεγάλο και σύνθετο πρόγραμμα, η άσκοπη χρήση μεγάλων πινάκων μπορεί να οδηγήσει ακόμη και σε αδυναμία εκτέλεσης του προγράμματος.
  6. Οι δυναμικές δομές έχουν σταθερό μέγεθος.

Μονάδες 12

ΛΥΣΗ: (περισσότερα…)