Επιλογή Σελίδας

Θέμα Β, 2017, Ημερήσια

ΘΕΜΑ Β
Β1. Δίνεται το παρακάτω απόσπασμα αλγορίθμου:
i<– …(1)
Όσο i≤ …(2) επανάλαβε
Αν i …(3) <> …(4) τότε
Γράψε i
Τέλοςαν
i <– i +  …(5)
Τέλος
επανάληψης
Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 5, που αντιστοιχούν στα κενά του παραπάνω αποσπάσματος, και δίπλα σε κάθε αριθμό τι πρέπει να συμπληρωθεί, ώστε με την εκτέλεσή του να εμφανίζονται οι τιμές:
4, 8, 16, 20, 28, 32, 40
Μονάδες 10
Β2. Το ακόλουθο πρόγραμμα έχει σκοπό να διαβάζει 10 θετικούς αριθμούς και να υπολογίζει και να εμφανίζει το γινόμενο όσων από αυτούς είναι πολλαπλάσιοι και του 3 και του 5 (συγχρόνως). Στο πρόγραμμα, όμως, υπάρχουν λάθη.
α) Να εντοπίσετε τα λάθη αυτά και στο τετράδιό σας να γράψετε τον αριθμό της γραμμής που βρίσκεται το λάθος και τον χαρακτηρισμό του (συντακτικό ή λογικό).
β) Στη συνέχεια να γράψετε το σωστό πρόγραμμα διορθώνοντας τα λάθη που εντοπίσατε.
1. Πρόγραμμα Αριθμοί
2. Μεταβλητές
3.    Πραγματικές: Χ
4.    Ακέραιες: Ρ, i
5. Αρχή
6. Ρ <– 0
7. Για i από 1 μέχρι 10
8.      Διάβασε Χ
9.     Αν Χ MOD 3 = 0 Ή MOD 5 = 0 τότε
10         Ρ <– Ρ * Χ
11.    Τέλοςεπανάληψης
12. Τέλος
επανάληψης
13. Γράψε Ρ
14 Τέλος_προγράμματος
Σημείωση: Θεωρείστε ότι κατά την εκτέλεση του προγράμματος θα δοθεί τουλάχιστον ένας τέτοιος αριθμός.
Μονάδες 10

ΔΤ5, Κεφάλαιο 8, Διόρθωσε τα λάθη του προγράμματος

Διάβασε προσεκτικά τα παρακάτω τμήματα προγράμματος. Ποια είναι τα λάθη; Διόρθωσέ τα, ώστε να λειτουργούν σωστά.Εκτέλεσε εικονικά τις εντολές στο χαρτί και σημείωνε τα αποτελέσματα που προκύπτουν. Με αυτόν τον τρόπο θα δεις τα λάθη και στη συνέχεια θα κάνεις τις διορθώσεις.

ΛΥΣΗ (περισσότερα…)

Θέμα A, Ερώτημα 4, 2013, Επαναληπτικές, Ημερήσια

Πρώτος ονομάζεται ένας φυσικός αριθμός, όταν έχει ακριβώς δύο διαιρέτες: τον εαυτό του και τη μονάδα. Ο παρακάτω αλγόριθμος γράφτηκε, έτσι ώστε να εμφανίζει τους πρώτους αριθμούς από το 2 μέχρι και το 100.

ΑΛΓΟΡΙΘΜΟΣ πρώτοι
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
Μ <i
ΓΙΑ j ΑΠΟ 0 ΜΕΧΡΙ i
ΑΝ i / j = 0 ΤΟΤΕ
Μ <- Μ + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Μ < 3 ΤΟΤΕ ΕΜΦΑΝΙΣΕ i
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ πρώτοι
Ο παραπάνω αλγόριθμος έχει λάθη. Να τον γράψετε στο τετράδιό σας, κάνοντας τις απαραίτητες διορθώσεις, ώστε να λειτουργεί σωστά, χωρίς την προσθήκη νέων εντολών.

Μονάδες 10

Τα θέματα σε pdf, 2013, Επαναληπτικές, Ημερήσια