Επιλογή Σελίδας

Θέμα Α, Ερώτημα 4, 2013, Μαΐου-Ιουνίου, Ημερήσια

α. Δίνεται τετραγωνικός πίνακας Π[100,100] και το παρακάτω τμήμα αλγορίθμου σε ψευδογλώσσα:
Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
Αν i<j τότε
Διάβασε Π[i,j]
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης

Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου χωρίς τη χρήση της δομής επιλογής, έτσι ώστε να επιτελεί την ίδια λειτουργία (μονάδες 4).
β. Να μεταφέρετε στο τετράδιό σας το παρακάτω τμήμα αλγορίθμου, έχοντας συμπληρώσει τις γραμμές εντολών 2, και 3 ώστε να εμφανίζει πάντα το μεγαλύτερο από τους δυο αριθμούς που διαβάστηκαν:
1. Διάβασε Α, Β
2. Αν Α … Β τότε
3. ……………..
4. Τέλος_αν
5. Εμφάνισε Α (μονάδες 4)

Μονάδες 8

Τα θέματα σε 2013, Μαΐου-Ιουνίου, Ημερήσια

Παράδειγμα 4, Τετράδιο Εργασιών, Επίλυση δευτεροβάθμιας εξίσωσης

Η περίπτωση της δευτεροβάθμιας εξίσωσης είναι παρόμοια. Αρχικά είναι απαραίτητο η τιμή του Α να είναι μη μηδενική, πράγμα που ελέγχεται κατά την είσοδο. Στη συνέχεια, για την εύρεση πραγματικών ριζών της εξίσωσης Αx2+Βx+Γ=0, πρέπει να ελεγχθεί αν η διακρίνουσα είναι θετική. Και πάλι καλείται ο αλγόριθμος Ρίζα, που επιστρέφει την τετραγωνική ρίζα ενός θετικού αριθμού.

Αλγόριθμος ΕξίσωσηΒ
Αρχήεπανάληψης
Διάβασε a
Μέχρις
ότου a≠0
Διάβασε b
Διάβασε c
delta ← bb-4ac
Αν delta ≥ 0 τότε
solution1 ← (-b+Piζα(delta))/(2
a)
solution2 ← (-b-Ρίζα(delta))/(2*a)
Εκτύπωσε solution1,solution2
Τέλος_αν
Τέλος ΕξίσωσηΒ

Παράδειγμα 2, Βιβλίο μαθητή, Σύγκριση αριθμών με απλή επιλογή

Να διαβαστεί ένας αριθμός και να εκτυπωθεί η απόλυτη τιμή του.
Όπως είναι γνωστό, η απόλυτη τιμή ενός αριθμού είναι ο ίδιος ο αριθμός, αν αυτός είναι θετικός ή μηδέν και ο αντίθετός του, αν είναι αρνητικός. Έτσι προκειμένου να βρεθεί η απόλυτη τιμή, αρκεί να ελεγχθεί, αν τυχόν ο δεδομένος αριθμός είναι αρνητικός, οπότε στην περίπτωση αυτή πρέπει να βρεθεί ο αντίθετός του. Ο συλλογισμός αυτός οδηγεί στον επόμενο αλγόριθμο.

Αλγόριθμος Παράδειγμα_2
Διάβασε a
Αν a < 0 τότε
a ← a*(-l)
Εκτύπωσε a
Τέλος Παράδειγμα_2

Στην παράσταση αλγορίθμων με ψευδογλώσσα η επιλογή υλοποιείται με την εντολή Αν…τότε. Η σύνταξη της εντολής είναι:

Αν συνθήκη τότε εντολή

και η λειτουργία της είναι: Αν ισχύει η συνθήκη (δηλαδή αν είναι αληθής), τότε μόνο εκτελείται η εντολή. Σε κάθε περίπτωση εκτελείται στη συνέχεια η εντολή, που ακολουθεί. Στην εντολή Αν…τότε είναι πιθανό, όταν ισχύει η συνθήκη, να απαιτείται η εκτέλεση περισσότερων από μία εντολές. Στην περίπτωση αυτή οι διαδοχικές εντολές γράφονται από κάτω και σε εσοχή, ενώ το σχήμα επιλογής κλείνει με τη λέξη Τέλος_αν. Π.χ.
Αν συνθήκη τότε
     εντολή_1
     εντολή_2
     …………..
     εντολή_ν
 Τέλος_αν
Όπως και στον αλγόριθμο του προηγούμενου παραδείγματος, εύκολα προκύπτει ότι η τιμή a είναι και είσοδος αλλά και έξοδος του αλγορίθμου. Επιπλέον, ο αλγόριθμος έχει καθορισμένη κάθε του εντολή (καθοριστικότητα), τελειώνει μετά από πεπερασμένο αριθμό βημάτων (περατότητα), ενώ κάθε εντολή του είναι ιδιαίτερα απλή κατά την εκτέλεσή της (αποτελεσματικότητα). Έτσι προκύπτει ότι ο αλγόριθμος αυτός πράγματι πληροί τα κριτήρια που περιγράφηκαν στην παράγραφο 2.1.

Παρατηρήσεις: Απόλυτη τιμή: |+5| = 5 και |-5| = 5, Η συνθήκη είναι μια λογική έκφραση.

par2kef2vm