Επιλογή Σελίδας

α. Δίνεται τετραγωνικός πίνακας Π[100,100] και το παρακάτω τμήμα αλγορίθμου σε ψευδογλώσσα:
Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
Αν i<j τότε
Διάβασε Π[i,j]
Τέλος_αν
Τέλος_επανάληψης
Τέλος_επανάληψης

Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου χωρίς τη χρήση της δομής επιλογής, έτσι ώστε να επιτελεί την ίδια λειτουργία (μονάδες 4).
β. Να μεταφέρετε στο τετράδιό σας το παρακάτω τμήμα αλγορίθμου, έχοντας συμπληρώσει τις γραμμές εντολών 2, και 3 ώστε να εμφανίζει πάντα το μεγαλύτερο από τους δυο αριθμούς που διαβάστηκαν:
1. Διάβασε Α, Β
2. Αν Α … Β τότε
3. ……………..
4. Τέλος_αν
5. Εμφάνισε Α (μονάδες 4)

Μονάδες 8

Τα θέματα σε 2013, Μαΐου-Ιουνίου, Ημερήσια

Share This