Επιλογή Σελίδας

Θέμα Α, Ερώτημα 5, 2016, Ημερήσια, Νέο

Δίδεται πίνακας ΠΙΝ[7] με τις παρακάτω τιμές:
2               5               8              12              15              17              22
και το παρακάτω τμήμα αλγορίθμου:

low <- 1 
 high <- 7
 found <- ΨΕΥΔΗΣ
 Όσο low ≤ high ΚΑΙ found = ΨΕΥΔΗΣ επανάλαβε
     mid <- (low+high) DIV 2
     Εμφάνισε ΠΙΝ[mid]
     Αν ΠΙΝ[mid] < Χ τότε
        low <- mid+1
     Αλλιώς_αν ΠΙΝ[mid] > Χ τότε
        high <- mid-1
     Αλλιώς
        found <- ΑΛΗΘΗΣ
     Τέλος_αν
 Τέλος_Επανάληψης

Να γράψετε στο τετράδιό σας τις τιμές οι οποίες θα εμφανιστούν για:
α) Χ=22 (μονάδες 3)
β) Χ=7 (μονάδες 3)
Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ (περισσότερα…)

Θέμα A, Ερώτημα 3, 2012, Επαναληπτικές, Ημερήσια

Ο παρακάτω αλγόριθμος προτάθηκε για να ελέγχει και να εκτυπώνει, αν ένας μη αρνητικός ακέραιος αριθμός είναι μονοψήφιος, διψήφιος ή τριψήφιος.

Στην περίπτωση που δοθεί αριθμός αρνητικός ή με περισσότερα από 3 ψηφία ο αλγόριθμος πρέπει να εμφανίζει το μήνυμα «Λάθος Δεδομένα».

Αλγόριθμος Ψηφία
Διάβασε x
Αν x >= 0 και x < 10 τότε
εμφάνισε ΄Μονοψήφιος΄
Αλλιώς_αν
x < 100 τότε
εμφάνισε ΄Διψήφιος΄
Αλλιώς_αν x < 1000 τότε
εμφάνισε
΄Τριψήφιος΄
Αλλιώς
εμφάνισε ΄Λάθος Δεδομένα΄
Τέλος_αν
Τέλος Ψηφία

Ο παραπάνω αλγόριθμος έχει λάθος. Δώστε ένα παράδειγμα εισόδου που θα καταδείξει το λάθος που υπάρχει στον αλγόριθμο (Μονάδες 3).
Στη συνέχεια να γράψετε τον αλγόριθμο στο τετράδιο σας κάνοντας τις απαραίτητες διορθώσεις, έτσι ώστε να λειτουργεί σωστά (Μονάδες 7).

Μονάδες 10

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

Ερώτημα 2, Θέμα Α, 2006, Επαναληπτικές, Ημερήσια

Δίνεται το παρακάτω τμήμα αλγορίθμου

ΑΝ ποσότητα <= 50 TOTE

Κόστος <- Ποσότητα * 580

ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 50 ΚΑΙ Ποσότητα <= 100 ΤΟΤΕ

Κόστος <- Ποσότητα * 520

 

ΑΛΛΙΩΣ_ΑΝ Ποσότητα > 100 ΚΑΙ Ποσότητα <= 200 ΤΟΤΕ

Κόστος <- Ποσότητα * 470

ΑΛΛΙΩΣ

Κόστος <- Ποσότητα * 440

ΤΕΛΟΣ_ΑΝ

Στο παραπάνω τμήμα αλγορίθμου, για το οποίο θεωρούμε ότι η ποσότητα είναι θετικός αριθμός, περιλαμβάνονται περιττοί έλεγχοι.

Να το ξαναγράψετε παραλείποντας τους περιττούς ελέγχους.

Μονάδες 4

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια