! Παράρτημα Α – Οδηγίες Μαθητή (β έκδοση) – 2.5 Επιλογή
! 4. Να γραφεί πρόγραμμα σε «ΓΛΩΣΣΑ», το οποίο να διαβάζει το όνομα ενός υπαλλήλου, τις ώρες
! εργασίας και το ωρομίσθιο του.
! Οι κρατήσεις που γίνονται στον υπάλληλο είναι 15%, αν ο μισθός του είναι μέχρι 1.000?,
! διαφορετικά είναι 20%.
! Σε περίπτωση που ο υπάλληλος έχει λιγότερες από 15 ώρες εργασίας τότε
! οι παραπάνω κρατήσεις μειώνονται κατά 2%.
! Υπόδειξη: Ο μισθός κάθε υπαλλήλου υπολογίζεται από τον τύπο:
! Ώρες x Ωρομίσθιο – Κρατήσεις

!Και οι κρατήσεις από τον τύπο:
!Κρατήσεις=(Ώρες x Ωρομίσθιο) x Ποσοστό/100

ΠΡΟΓΡΑΜΜΑ par_a_2_5_epilogi_4
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ω, ωρ, μισθός, κρατήσεις
ΧΑΡΑΚΤΗΡΕΣ: ον
ΑΡΧΗ
ΔΙΑΒΑΣΕ ον, ω, ωρ

μισθός <-- ω * ωρ Αν ω > 15 τότε
Αν μισθός > 1000 τότε
κρατήσεις <-- μισθός * 0.20 αλλιώς κρατήσεις <-- μισθός * 0.15 Τέλος_αν αλλιώς Αν μισθός > 1000 τότε
κρατήσεις <– μισθός * 0.18
αλλιώς
κρατήσεις <– μισθός * 0.13
Τέλοςαν
Τέλος
αν

! λύση και λογικές προτάσεις και απλές επιλογές
! Αν ω > 15 και μισθός > 1000 τότε
! κρατήσεις <-- μισθός * 0.20 ! τέλος_αν ! αν ω > 15 και μισθός < 1000 τότε
! κρατήσεις <-- μισθός * 0.15 ! τέλος_αν ! αν ω < 15 και μισθός > 1000 τότε
! κρατήσεις <– μισθός * 0.18
! τέλοςαν
! αν ω < 15 και μισθός < 1000 τότε
! κρατήσεις <– μισθός * 0.13
! τέλος
αν

! λύση και λογικές προτάσεις και πολλαπλή επιλογή
! Αν ω > 15 και μισθός > 1000 τότε
! κρατήσεις <-- μισθός * 0.20 ! αλλιώς_αν ω > 15 και μισθός < 1000 τότε
! κρατήσεις <-- μισθός * 0.15 ! αλλιώς_αν ω < 15 και μισθός > 1000 τότε
! κρατήσεις <– μισθός * 0.18
! αλλιώςαν ω < 15 και μισθός < 1000 τότε
! κρατήσεις <– μισθός * 0.13
! τέλος
αν

μισθός <– μίσθος – κρατήσεις
γράψε ον, μισθός

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Share This