Επιλογή Σελίδας

Μία εταιρεία κατασκευής αυτοκινήτων έχει μετρήσεις από το επίπεδο θορύβου όλων των μοντέλων της (σε decibel -dB). Οι μετρήσεις γίνονται για διαφορετικές ταχύτητες και δίνονται από τον παρακάτω πίνακα:
Μοντέλο

Να γραφεί πρόγραμμα το οποίο θα υπολογίζει και θα τυπώνει το μέσο επίπεδο θορύβου για κάθε μοντέλο, το μέσο επίπεδο θορύβου για κάθε ταχύτητα και το συνολικό μέσο επίπεδο θορύβου όλων των αυτοκινήτων.

ΠΡΟΓΡΑΜΜΑ Αυτοκίνητα 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Θόρυβος[4,5],I,J,Ταχύτητα[5],Άθροισμα, Συν_Άθροισμα 
ΧΑΡΑΚΤΗΡΕΣ:Μοντέλο[4] 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ,Συν_ΜΟ 

!Εισαγωγή δεδομένων 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙΓΡΑΨΕ 'Δώσε ταχύτητα.. '
    ΔΙΑΒΑΣΕ Ταχύτητα[Ι] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ    ΓΡΑΨΕ 'Δώσε μοντέλο.. '  
    ΔΙΑΒΑΣΕ Μοντέλο[Ι]  
    ΓΡΑΨΕ 'Δώσε επίπεδα θορύβου.. '
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙΔΙΑΒΑΣΕ Θόρυβος[I,J]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 

! Υπολογισμοί μέσων τιμών 
Συν_Άθροισμα <-- 0 
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 4   
    Άθροισμα <-- 0  
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 5    
        Άθροισμα <-- Άθροισμα+Θόρυβος[I,J]  
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Συν_Άθροισμα <-- Συν_Άθροισμα+Άθροισμα   
    ΜΟ <-- Άθροισμα/5    
    ΓΡΑΨΕ Μοντέλο[I], ' :', ΜΟ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 5   
    Άθροισμα <-- 0  
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 4   
        Άθροισμα <-- Άθροισμα+Θόρυβος[I,J]  
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    ΜΟ <-- Άθροισμα/4  
    ΓΡΑΨΕ Ταχύτητα[J] ' :', ΜΟ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ  
Συν_ΜΟ <-- Συν_Άθροισμα/20 
ΓΡΑΨΕ 'Συνολικό μέσο επίπεδο θορύβου :', Συν_ΜΟ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This