Επιλογή Σελίδας

Να γράψετε ένα πρόγραμμα το οποίο να διαβάζει τον αριθμό των τερμάτων που σημειώθηκαν στους αγώνες ποδοσφαίρου μίας αγωνιστικής της Α κατηγορίας (9 τιμές), να υπολογίζει το μέσο αριθμό τερμάτων καθώς και το εύρος των τερμάτων (δηλαδή τη διαφορά της μεγαλύτερης από τη μικρότερη τιμή).

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Ποδόσφαιρο
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: αγώνας, Άθροισμα, εύρος, μέγιστος, ελάχιστος, Τέρματα[9]
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    ΓΡΑΨΕ 'Δώσε αριθμό τερμάτων αγώνα ', αγώνας
    ΔΙΑΒΑΣΕ Τέρματα[Αγώνας]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΘΡΟΙΣΜΑ <-- 0
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    Άθροισμα <-- Άθροισμα + Τέρματα[Αγώνας]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ <-- Άθροισμα / 9
ΓΡΑΨΕ 'Ο μέσος αριθμός τερμάτων είναι ', ΜΟ

μέγιστος <-- Τέρματα[1]
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    ΑΝ Τέρματα[αγώνας] > μέγιστος ΤΟΤΕ
       μέγιστος <-- Τέρματα[αγώνας]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ελάχιστος <-- Τέρματα[1]
ΓΙΑ αγώνας ΑΠΟ 1 ΜΕΧΡΙ 9
    ΑΝ Τέρματα[αγώνας] < ελάχιστος ΤΟΤΕ
       ελάχιστος <-- Τέρματα[αγώνας]
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

εύρος <-- μέγιστος - ελάχιστος
ΓΡΑΨΕ 'Το εύρος τερμάτων είναι ', εύρος
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This