Να γράψετε την άσκηση ΔΕ4 (ρύπανση ατμόσφαιρας) του προηγουμένου κεφαλαίου χρησιμοποιώντας πίνακες για την αποθήκευση των τιμών καθώς και των ονομάτων των σταθμών μέτρησης.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Ρύποι
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:NO2[5,6], O3[5,6], μετρήσεις, σταθμός
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ_NO2[5], ΜΟ_O3[5], max_NO2, max_O3, Αθροιστής_NO2, Αθροιστής_O3
ΑΡΧΗ 
ΓΙΑ σταθμός ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'Μετρήσεις Σταθμού ', σταθμός
    ΓΙΑ μετρήσεις ΑΠΟ 1 ΜΕΧΡΙ 6 
        ΓΡΑΨΕ 'Δώσε την τιμή του Διοξειδίου του αζώτου ', μετρήσεις, ' από 6'
        ΔΙΑΒΑΣΕ NO2[σταθμός, μετρήσεις]
        ΓΡΑΨΕ 'Δώσε την τιμή του Όζοντος', μετρήσεις, ' από 6'
        ΔΙΑΒΑΣΕ O3[σταθμός, μετρήσεις] 
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Αθροιστής_NO2 <-- 0
Αθροιστής_O3 <-- 0 
ΓΙΑ σταθμός ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΙΑ μετρήσεις ΑΠΟ 1 ΜΕΧΡΙ 6
        Αθροιστής_NO2 <-- Αθροιστής_NO2 + NO2[σταθμός, μετρήσεις] 
        Αθροιστής_O3 <-- Αθροιστής_O3 + O3[σταθμός, μετρήσεις]  
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΜΟ_NO2[σταθμός] <-- Αθροιστής_NO2 / 6 
ΜΟ_O3[σταθμός] <-- ΑΘροιστής_O3 / 6 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
max_NO2 <-- ΜΟ_NO2[1] 
max_O3 <-- ΜΟ_O3[1] 
ΓΙΑ σταθμός ΑΠΟ 2 ΜΕΧΡΙ 5  
    ΑΝ max_NO2 < ΜΟ_NO2[σταθμός] ΤΟΤΕ 
       max_NO2 <-- ΜΟ_NO2[σταθμός]  
    ΤΕΛΟΣ_ΑΝ  
    ΑΝ max_O3 < ΜΟ_O3[σταθμός] ΤΟΤΕ 
       max_O3 <-- ΜΟ_O3[σταθμός] 
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    ΑΝ max_NO2 > 700 Ή max_O3 > 500 ΤΟΤΕ  
       ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΑΠΑΓΟΡΕΥΣΗ ΚΥΚΛΟΦΟΡΙΑΣ' 
    ΑΛΛΙΩΣ_ΑΝ max_NO2 > 500 Ή max_O3 > 300 ΤΟΤΕ 
           ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ' 
    ΑΛΛΙΩΣ_ΑΝ max_NO2 > 400 Ή max_O3 > 250 ΤΟΤΕ  
           ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ' 
ΑΛΛΙΩΣ  
       ΓΡΑΨΕ 'Ρύποι μέσα στα όρια' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This