Επιλογή Σελίδας

Να επεκτείνεις το παράδειγμα 1, τον υπολογισμό της ατμοσφαιρικής ρύπανσης, έτσι ώστε να παίρνει 6 τιμές ανά ώρα από 5 διαφορετικούς σταθμούς μέτρησης για τους δύο ρύπους. Το πρόγραμμα
• να υπολογίζει τη μέση τιμή κάθε ρύπου ανά ώρα και ανά σταθμό
• να βρίσκει τη μέγιστη μέση τιμή για κάθε ρύπο
• να ελέγχει τις μέγιστες αυτές τιμές με τα όρια που δόθηκαν
Το πρόγραμμα να εκτελεστεί με δεδομένα τις πραγματικές τιμές ρύπων που μετρήθηκαν τη χθεσινή ημέρα. Οι τιμές αυτές δίδονται από το τμήμα ποιότητας της ατμόσφαιρας του ΥΠΕΧΩΔΕ και βρίσκονται στη διεύθυνση: www.minenv.gr

ΛΥΣΗ 

ΠΡΟΓΡΑΜΜΑ Ρύποι 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: NO2, O3, μετρήσεις, σταθμός
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ1, ΜΟ2, MAX1, MAX2, S1, S2
ΑΡΧΗ 
MAX1 <-- 0
MAX2 <-- 0
ΓΙΑ σταθμός ΑΠΟ 1 ΜΕΧΡΙ 5
S1 <-- 0
S2 <-- 0
ΓΡΑΨΕ 'Μετρήσεις Σταθμού ', σταθμός
ΓΙΑ μετρήσεις ΑΠΟ 1 ΜΕΧΡΙ 6 
    ΓΡΑΨΕ 'Δώσε την τιμή του Διοξειδίου του αζώτου ', μετρήσεις, ' από 6'
    ΔΙΑΒΑΣΕ NO2
    S1 <-- S1 + NO2
    ΓΡΑΨΕ 'Δώσε την τιμή του Όζοντος', μετρήσεις, ' από 6'
    ΔΙΑΒΑΣΕ O3 
    S2 <-- S2 + O3
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ1 <-- S1/6
ΜΟ2 <-- S2/6
ΑΝ ΜΟ1 > MAX1 ΤΟΤΕ
   MAX1 <-- ΜΟ1
ΤΕΛΟΣ_ΑΝ
ΑΝ ΜΟ2 > MAX2 ΤΟΤΕ
   MAX2 <-- ΜΟ2
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ MAX1>700 Ή MAX2 > 500 ΤΟΤΕ 
   ΓΡΑΨΕ 'ΠΑΡΑ ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΑΠΑΓΟΡΕΥΣΗ ΚΥΚΛΟΦΟΡΙΑΣ'
ΑΛΛΙΩΣ_ΑΝ MAX1 > 500 Ή MAX2 > 300 ΤΟΤΕ 
       ΓΡΑΨΕ 'ΠΟΛΥ ΥΨΗΛΟΙ ΡΥΠΟΙ ΕΚΤΑΚΤΑ ΜΕΤΡΑ'
ΑΛΛΙΩΣ_ΑΝ MAX1 > 400 Ή MAX2 > 250 ΤΟΤΕ 
       ΓΡΑΨΕ 'ΠΡΟΣΟΧΗ ΥΨΗΛΟΙ ΡΥΠΟΙ'
ΑΛΛΙΩΣ 
   ΓΡΑΨΕ 'Ρύποι μέσα στα όρια' 
ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This