Επιλογή Σελίδας

Να γράψετε πρόγραμμα το οποίο να ταξινομεί τα μοντέλα αυτοκινήτων του παραδείγματος 2, κατά αύξουσα σειρά του μέσου επιπέδου θορύβου κάθε μοντέλου.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΗΧΟΡΥΠΑΝΣΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ταχύτητα[5], Θόρυβος[4,5], i, j, Ολ_Θόρυβος
ΠΡΑΓΜΑΤΙΚΕΣ: Μέσος_Θόρυβος[4], βοηθητική1
ΧΑΡΑΚΤΗΡΕΣ: Μοντέλο[4], βοηθητική2
ΑΡΧΗ
!Εισαγωγή Δεδομένων
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ 'Δώσε ταχύτητα'
    ΔΙΑΒΑΣΕ Ταχύτητα[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ 'Δώσε Μοντέλο'
    ΔΙΑΒΑΣΕ Μοντέλο[i]
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
        ΓΡΑΨΕ 'Δώσε τα επίπεδα θορύβου του μοντέλου ', Μοντέλο[i], 'στα ', Ταχύτητα[j], 'Km/h'
        ΔΙΑΒΑΣΕ Θόρυβος[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Άθροισμα κατά γραμμές του Θόρυβος 
!Υπολογισμός του μέσου θόρυβου ανά μοντέλο.
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
    Ολ_Θόρυβος <--0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
        Ολ_Θόρυβος <-- Ολ_Θόρυβος + Θόρυβος[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Μέσος_Θόρυβος[i] <-- Ολ_Θόρυβος / 5
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Ταξινόμηση του Μοντέλα με βάση το επίπεδο θορύβου (Μέσος_Θόρυβος)
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 5
    ΓΙΑ j ΑΠΟ 5 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
       ΑΝ Μέσος_Θόρυβος[j-1]>Μέσος_Θόρυβος[j] ΤΟΤΕ
          βοηθητική1 <-- Μέσος_Θόρυβος[j]
          Μέσος_Θόρυβος[j] <-- Μέσος_Θόρυβος[j-1]
          Μέσος_Θόρυβος[j-1]<-- βοηθητική1
          βοηθητική2 <-- Μοντέλο[j]
          Μοντέλο[j] <-- Μοντέλο[j-1]
          Μοντέλο[j] <-- βοηθητική2
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ Μοντέλο[i]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This