Επιλογή Σελίδας

Μια πολυκατοικία έχει 5 ορόφους, με 8 διαμερίσματα (Δ1, Δ2, …,Δ8) σε κάθε όροφο. Τα διαμερίσματα Δ1 όλων των ορόφων έχουν το ίδιο εμβαδό (Ε1), τα διαμερίσματα Δ2 όλων των ορόφων έχουν το ίδιο εμβαδό (Ε2) κ.ο.κ. Το ποσό των κοινοχρήστων της πολυκατοικίας κατανέμεται στους 5 ορόφους, σύμφωνα με το ποσοστό συμμετοχής του κάθε ορόφου, όπως φαίνεται στον Πίνακα III.

Όροφος Ποσοστό  συμμετοχής
1ος 5%
2ος 15%
3ος 20%
4ος 25%
5ος 35%

Πίνακας  ΙΙΙ

Το ποσό των κοινοχρήστων του κάθε ορόφου κατανέμεται στα διαμερίσματα του ορόφου αυτού, ανάλογα με το εμβαδό του καθενός διαμερίσματος.
Να γράψετε πρόγραμμα, το οποίο:
Δ1.     Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων.
Μονάδες 2
Δ2.     Να ζητάει:
α.     Το συνολικό ποσό κοινοχρήστων της πολυκατοικίας (μονάδα 1).
β.     Τα εμβαδά Ε1, Ε2, … Ε8. (μονάδα 1).
Μονάδες 2
Δ3. Να υπολογίζει το ποσό των κοινοχρήστων που αναλογεί σε κάθε όροφο της πολυκατοικίας.
Μονάδες 4
Δ4. Να υπολογίζει το ποσό των κοινοχρήστων που αναλογεί σε κάθε διαμέρισμα της πολυκατοικίας.
Μονάδες 7
Δ5. Να αναζητά και να εμφανίζει τον αριθμό ορόφου (1-5) και τον αριθμό διαμερίσματος (1-8) ενός διαμερίσματος στο οποίο αναλογεί ποσό κοινοχρήστων μεγαλύτερο του μέσου όρου όλης της πολυκατοικίας. Η αναζήτηση να ξεκινά από τον 1ο όροφο και για κάθε όροφο να ξεκινά από το διαμέρισμα Δ8. Η αναζήτηση να τερματίζεται μόλις βρεθεί ένα τέτοιο διαμέρισμα.
Μονάδες 5

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

ΘΕΜΑ_Δ_2015_ΕΠΑΝ_ΗΜΕΡ [δεδομένα]

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ_2015_ΕΠΑΝ_ΗΜΕΡ
 ! Δ1
 ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, j
 ΠΡΑΓΜΑΤΙΚΕΣ: ΚΟΙΝ[5], ΚΟΙΝΟΧΡΗΣΤΑ, ΔΙΑΜ[5,8] , ΕΜΒ[8] , ΕΜΒ_ΟΡ, Sum, ΜΟ
 ΛΟΓΙΚΕΣ: βρέθηκε

ΑΡΧΗ
! Δ2 Εισαγωγή Δεδομένων
 ΓΡΑΨΕ 'ΔΩΣΕ ΠΟΣΟ ΚΟΙΝΟΧΡΗΣΤΩΝ'
 ΔΙΑΒΑΣΕ ΚΟΙΝΟΧΡΗΣΤΑ
 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
     ΓΡΑΨΕ 'ΔΩΣΤΕ ΕΜΒΑΔΑ ΔΙΑΜΕΡΙΣΜΑΤΩΝ Ε', j
     ΔΙΑΒΑΣΕ ΕΜΒ[j]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ3
 ΚΟΙΝ[1] <-- ΚΟΙΝΟΧΡΗΣΤΑ * 5/100
 ΚΟΙΝ[2] <-- ΚΟΙΝΟΧΡΗΣΤΑ * 15/100
 ΚΟΙΝ[3] <-- ΚΟΙΝΟΧΡΗΣΤΑ * 20/100
 ΚΟΙΝ[4] <-- ΚΟΙΝΟΧΡΗΣΤΑ * 25/100
 ΚΟΙΝ[5] <-- ΚΟΙΝΟΧΡΗΣΤΑ * 35/100

! Δ4
 ΕΜΒ_ΟΡ <-- 0
 ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
     ΕΜΒ_ΟΡ <-- ΕΜΒ_ΟΡ + ΕΜΒ[j]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
         ΔΙΑΜ[i,j] <-- ΚΟΙΝ[i] * ΕΜΒ[j] / ΕΜΒ_ΟΡ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ5
 ! Υπολογισμός ΜΟ Κοινοχρήστων πολυκατοικίας
 Sum <-- 0
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
     ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 8
         Sum <-- Sum + ΔΙΑΜ[i,j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΜΟ <-- Sum / 40
 ΓΡΑΨΕ 'ΔΙΑΜΕΡΙΣΜΑ ΜΕ ΚΟΙΝΟΧΡΗΣΤΑ > ΜΟ'
 βρέθηκε <-- ΨΕΥΔΗΣ
 i <-- 1
 ΌΣΟ i<=5 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
     j <-- 8
     ΌΣΟ j>=1 ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
         ΑΝ ΔΙΑΜ[i,j] > ΜΟ ΤΟΤΕ
            ΓΡΑΨΕ 'ΟΡΟΦΟΣ:', i, ' ΔΙΑΜΕΡΙΣΜΑ: ', j
                  βρέθηκε <-- Αληθής
         ΤΕΛΟΣ_ΑΝ
         j <-- j-1
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 i <-- i + 1
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This