Επιλογή Σελίδας

Δίνεται ο μονοδιάστατος πίνακας C με έξι στοιχεία που έχουν αντίστοιχα τις παρακάτω τιμές:

2, 5, 15, -1, 32, 14 και το παρακάτω τμήμα αλγορίθμου:

min <- 100

Max<-100

Για i από 1 μέχρι 6 με_βήμα 2

Α <- C[i]

B<- C[i+1]

Αν A<Β τότε

Lmin <- A

Lmax <- B

αλλιώς

Lmin <- Β

Lmax <- Α

Τέλος_αν

Αν Lmin<min τότε

min <- Lmin

Τέλος_αν

Αν Lmax>max τότε

max <- Lmax

Τέλος_αν

Εκτύπωσε   Α, Β, Lmin, Lmax, min, max

Τέλος_επανάληψης

D <- max_min

Εκτύπωσε D

 

Να εκτελέσετε το παραπάνω τμήμα αλγορίθμου και να γράψετε στο τετράδιό σας:

α. Τις τιμές των μεταβλητών Α, Β, Lmin, Lmax, min και max, όπως αυτές εκτυπώνονται σε κάθε επανάληψη.

Μονάδες 18

β. Την τιμή της μεταβλητής D που εκτυπώνεται.

Μονάδες 2

Τα θέματα σε pdf, 2004, Μαΐου-Ιουνίου, Ημερήσια

Share This