Επιλογή Σελίδας

Θέμα Α, Ερώτημα 2, 2014, Επαναληπτικές, Ημερήσια

α.    Να δώσετε τον ορισμό της δομής ενός προβλήματος. (μονάδες 4)

β.   Να κάνετε τη διαγραμματική αναπαράσταση του προβλήματος «Αντιμετώπιση ναρκωτικών», που περιγράφεται παρακάτω:

Για την αντιμετώπιση του προβλήματος των ναρκωτικών, απαιτείται τόσο η πρόληψη όσο και η θεραπεία των εξαρτημένων ατόμων, ενώ σημαντικό ρόλο έχει και η διαδικασία επανένταξης των απεξαρτημένων ατόμων στην κοινωνία. Η πρόληψη περιλαμβάνει την ενημέρωση των πολιτών. Εξίσου σημαντική για την πρόληψη κρίνεται η ανάπτυξη ενδιαφερόντων για άτομα «αυξημένης προδιάθεσης». Στον τομέα της θεραπείας, εκτός από την ενίσχυση των υπαρχουσών θεραπευτικών κοινοτήτων, σκόπιμη είναι και η δημιουργία κατάλληλων τμημάτων στα δημόσια νοσοκομεία. Σημαντικοί παράγοντες για αποτελεσματική επανένταξη είναι τόσο η καταπολέμηση της κοινωνικής προκατάληψης, όσο και η επιδότηση θέσεων εργασίας για τους απεξαρτημένους πρώην χρήστες. (μονάδες 6)

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

Θέμα Α, Ερώτημα 5, 2014, Επαναληπτικές, Ημερήσια

α. Τι ονομάζεται πίνακας στη ΓΛΩΣΣΑ; (μονάδες 2)

β. Δίνεται o παρακάτω αλγόριθμος, ο οποίος αντιγράφει τα Ν στοιχεία ενός μονοδιάστατου πίνακα Α, ακολουθούμενα από τα Μ στοιχεία ενός μονοδιάστατου πίνακα Β, σε ένα μονοδιάστατο πίνακα Γ με Ν+Μ στοιχεία.

Αλγόριθμος Συνένωση
Δεδομένα //Α, Ν, Β, Μ//
Για i απόμέχρι
Γ[…]<-Α[…]
Τέλος_επανάληψης
Για i απόμέχρι
Γ[…] <Β[…]
Τέλος_επανάληψης
Αποτελέσματα //Γ//
Τέλος Συνένωση

Να ξαναγράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο με τα κενά συμπληρωμένα, έτσι ώστε να επιτελεί την επιθυμητή λειτουργία. (μονάδες 8)

Μονάδες 10

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια