Επιλογή Σελίδας

15, Πίνακες, Παράρτημα Β, ΙΕΠ, ΕΠΥ, 27ος Π.Δ.Π (2015) Α’ Φάση, Θέμα Λυκείου, Κυλικείο

Μια ομάδα παιδιών στέκονται σε μια ευθεία γραμμή, το ένα πίσω από το άλλο, περιμένοντας τη σειρά τους στο κυλικείο του σχολείου. Το πρώτο παιδί προφανώς βλέπει την είσοδο του κυλικείου, όσα παιδιά όμως στέκονται πίσω του δεν είναι σίγουρο ότι και αυτά τη βλέπουν. Για να βλέπει ένα παιδί την είσοδο του κυλικείου πρέπει όλα τα παιδιά που στέκονται μπροστά του να είναι κοντύτερα από αυτό.

Πρόβλημα:

Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο, αφού διαβάσει τα ύψη 20 παιδιών που βρίσκονται το ένα πίσω από το άλλο θα εμφανίζει τον αριθμό των παιδιών που βλέπουν την είσοδο του κυλικείου. ΕΠΥ, 27ος ΠΔΠ (2015), Α’ Φάση

ΛΥΣΗ (περισσότερα…)

Παράδειγμα 3, Κεφάλαιο 8, Βιβλίο, Άθροισμα και Πλήθος αριθμών

Στο προηγούμενο παράδειγμα ας υποθέσουμε ότι οι μετρήσεις είναι υποχρεωτικά θετικοί αριθμοί και ότι μετά την εισαγωγή κάθε αριθμού υπάρχει η ερώτηση αν θα εισαγάγουμε άλλο. Η διαδικασία θα τελειώσει, όταν η απάντηση θα είναι Όχι (ο ή Ο).

ΠΡΟΓΡΑΜΜΑ Άθροισμα2 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ:Χ, Άθροισμα, Πλήθος 
ΠΡΑΓΜΑΤΙΚΕΣ:ΜΟ 
ΧΑΡΑΚΤΗΡΕΣ:Επιλογή 
ΑΡΧΗ 
Πλήθος <-- 0 
Άθροισμα <-- 0 
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
       ! Έλεγχος δεδομένων 
       ΓΡΑΨΕ 'Δώσε Αριθμό' 
       ΔΙΑΒΑΣΕ Χ 
       ΑΝ Χ <= 0 ΤΟΤΕ 
          ΓΡΑΨΕ 'Λάθος Αριθμός, Παρακαλώ δώστε ξανά...' 
       ΤΕΛΟΣ_ΑΝ 
       ! Αν το X δεν είναι θετικό εισάγουμε νέο αριθμό 
    ΜΕΧΡΙΣ_ΟΤΟΥ Χ>0 
    Άθροισμα <-- Άθροισμα+Χ 
    Πλήθος <-- Πλήθος+1 
    ΓΡΑΨΕ 'Νέα μέτρηση ;' 
    ΔΙΑΒΑΣΕ Επιλογή ! Αν η επιλογή είναι Ο ή ο τότε σταματάει η επανάληψη
ΜΕΧΡΙΣ_ΟΤΟΥ Επιλογή='Ο' Ή Επιλογή='ο' 
ΜΟ <-- Άθροισμα/Πλήθος 
ΓΡΑΨΕ 'Άθροισμα =' , Άθροισμα 
ΓΡΑΨΕ 'Μέσος όρος =', ΜΟ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ