Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο:
α. Να διαβάζει τα ονόματα δέκα κινηματογράφων και τις αντίστοιχες εισπράξεις τους για κάθε ημέρα μίας εβδομάδας.
β. Να υπολογίζει και να εκτυπώνει το άθροισμα των εισπράξεων κάθε κινηματογράφου, καθώς και τον κινηματογράφο με τη μέγιστη συνολική είσπραξη.
γ. Να υπολογίζει και να εκτυπώνει το άθροισμα των εισπράξεων κάθε ημέρας, καθώς και την ημέρα με τη μέγιστη συνολική είσπραξη.

Για την επίλυση του προβλήματος πρέπει να χρησιμοποιηθούν δύο πίνακες. Ο πρώτος θα περιέχει μόνο τα ονόματα των κινηματογράφων, θα είναι δηλαδή ένας μονοδιάστατος πίνακας χαρακτήρων με δέκα γραμμές. Ο δεύτερος θα περιέχει τις εισπράξεις, θα είναι ένας πίνακας δισδιάστατος ακεραίων αριθμών με δέκα γραμμές, μία για κάθε κινηματογράφο και επτά στήλες, μία για κάθε ημέρα. Το πρόγραμμα ουσιαστικά αποτελείται από τρία τμήματα:

  1. Την ανάγνωση των δεδομένων και την καταχώρησή του στους αντίστοιχους πίνακες, Ονόματα και Εισπράξεις.
  2. Τον υπολογισμό του συνόλου των εισπράξεων ανά κινηματογράφο και την εύρεση της μέγιστης συνολικής είσπραξης, δηλαδή του αθροίσματος των γραμμών του πίνακα.
  3. Τον υπολογισμό του συνόλου των εισπράξεων ανά ημέρα και την εύρεση της μέγιστης συνολικής είσπραξης, δηλαδή του αθροίσματος των στηλών του πίνακα.

Προσέξτε τις διαφορές του δεύτερου και του τρίτου τμήματος. Και οι δύο χρησιμοποιούν δύο εμφωλευμένους βρόχους, ένα για τις γραμμές και ένα για τις στήλες αλλά σε διαφορετική σειρά.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Κινηματογράφοι 
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:Εισπράξεις[10,7], i,j, Άθροισμα, Μέγιστο, Θέση
ΧΑΡΑΚΤΗΡΕΣ:Ονόματα[10]
ΑΡΧΗ
! Εισαγωγή δεδομένων και εκχώρησή τους σε δύο πίνακες
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε το όνομα του ',i,' κινηματογράφου'
    ΔΙΑΒΑΣΕ Ονόματα[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 7
        ΓΡΑΨΕ 'Δώσε την ', j,'-η είσπραξη'
        ΔΙΑΒΑΣΕ Εισπράξεις[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
! Αθροισμα των στοιχείων του πίνακα Εισπράξεις ανά γραμμή
! και υπολογισμός του μέγιστου αθροίσματος
Μέγιστο <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    Άθροισμα <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 7
        Άθροισμα <-- Άθροισμα+Εισπράξεις[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Συνολ. είσπραξη ',Ονόματα[i], '=', Άθροισμα
    ΑΝ Μέγιστο < Άθροισμα ΤΟΤΕ
       Μέγιστο <-- Άθροισμα
       Θέση <-- i
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ 'Μέγ.συνολ.είσπραξη ',Μέγιστο,'στον ',Ονόματα[Θέση]
!Αθροισμα των στοιχείων του πίνακα Εισπράξεις ανά στήλη
!και υπολογισμός του μέγιστου αθροίσματος 
Μέγιστο <-- 0
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 7
    Άθροισμα <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
        Άθροισμα <-- Άθροισμα + Εισπράξεις[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Συνολ. είσπραξη',j,'-ης ημέρας = ', Άθροισμα
    ΑΝ Μέγιστο < Άθροισμα ΤΟΤΕ
       Μέγιστο <-- Άθροισμα
       Θέση <-- j
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ 'Μέγ.συν.είσπραξη ',Μέγιστο,'την ',Θέση,'-η ημέρα'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This