Επιλογή Σελίδας

Να γραφεί πρόγραμμα το οποίο να υπολογίζει τα βασικά στατιστικά μεγέθη, τη μέση τιμή, την τυπική απόκλιση και τη διάμεσο τιμή Ν ακεραίων αριθμών, όπου το Ν είναι από 2 μέχρι 100.
Τα δεδομένα εισάγονται από το πληκτρολόγιο και καταχωρούνται στον πίνακα Χ.

Η μέση τιμή μ δίνεται από τον τύπο  

Η τυπική απόκλιση σ δίνεται από τον τύπο 

Για να βρεθεί η διάμεσος τιμή πρέπει υποχρεωτικά οι αριθμοί να ταξινομηθούν κατά αύξουσα σειρά. Τότε διάμεσος τιμή, είναι η τιμή για την οποία οι μισοί αριθμοί είναι μικρότεροι και οι άλλοι μισοί μεγαλύτεροι. Στην περίπτωση που το πλήθος των αριθμών είναι περιττό, τότε διάμεσος είναι ο μεσαίος, ενώ στην περίπτωση που είναι άρτιο, τότε διάμεσος είναι το ημιάθροισμα των δύο μεσαίων αριθμών. Η ταξινόμηση των στοιχείων γίνεται με τη μέθοδο ταξινόμησης ευθείας ανταλλαγής, η οποία παρουσιάστηκε στο κεφάλαιο 3.

ΠΡΟΓΡΑΜΜΑ Στατιστική 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ : i, Ν, Χ[100], Άθροισμα, Άθροισμα_2, Βοηθητική, ΝΖ, ΝΜ, j ! Παρόραμα δεν δηλώθηκε η j
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΤ, Τυπ_Απόκλιση, Διάμεσος 
ΑΡΧΗ 
! Εισαγωγή δεδομένων 
ΓΡΑΨΕ 'Δώσε το πλήθος των αριθμών (μέγιστο 100)' 
ΔΙΆΒΑΣΕ Ν 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
    ΓΡΑΨΕ 'Δώσε τον ',i,'-το αριθμό' 
    ΔΙΑΒΑΣΕ Χ[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
! Υπολογισμός αθροισμάτων 
Άθροισμα <-- 0 
Άθροισμα_2 <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν 
   ! ΓΡΑΨΕ 'Δώσε τον',i,'-το αριθμό'  Παρόραμα - Ξαναδιαβάζει τους αριθμούς
   ! ΔΙΑΒΑΣΕ Χ[i] 
    Άθροισμα <-- Άθροισμα + Χ[i] 
    Άθροισμα_2 <-- Άθροισμα_2 + Χ[i]^2 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
! Υπολογισμός μέσου όρου 
ΜΤ <-- Άθροισμα/Ν 
!Υπολογισμός τυπικής απόκλισης 
Τυπ_Απόκλιση <-- Τ_Ρ(Άθροισμα_2/Ν - ΜΤ^2) 
!Ταξινόμηση των στοιχείων του πίνακα 
ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν 
    ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1 
       ΑΝ Χ[j-1] > Χ[j] ΤΟΤΕ 
! Αντιμετάθεση των στοιχείων j και j-1 
      Βοηθητική <-- Χ[j-1] 
      Χ[j-i] <-- Χ[j] 
      Χ[j] <-- Βοηθητική 
      ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ! j 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ! i 
!Υπολογισμός διαμέσου
ΝΖ <--Ν DIV 2
ΝΜ <--(Ν DIV 2) + 1
ΑΝ Ν MOD 2 =0 ΤΟΤΕ 
   Διάμεσος <-- (Χ[Ν div 2]+Χ[(Ν div 2)]+1)/2 !Παρόραμα - Πρόβλημα με την δήλωση τύπου του Ν
ΑΛΛΙΩΣ 
   Διάμεσος <-- Χ[(Ν+1)div 2] ! Παρόραμα
ΤΕΛΟΣ_ΑΝ 
! Εκτύπωση αποτελεσμάτων 
ΓΡΑΨΕ 'ΑΠΟΤΕΛΕΣΜΑΤΑ' 
ΓΡΑΨΕ '============' 
ΓΡΑΨΕ 'Πλήθος τιμών =', Ν 
ΓΡΑΨΕ 'Μέση τιμή = ', ΜΤ 
ΓΡΑΨΕ 'Τυπική απόκλιση = ', Τυπ_Απόκλιση 
ΓΡΑΨΕ 'Διάμεσος = ', Διάμεσος 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This