Να γραφεί πρόγραμμα που να υπολογίζει τη μέση θερμοκρασία κάθε πόλης για τον προηγούμενο πίνακα θερμοκρασιών (δίδονται 30 θερμοκρασίες 10 πόλεων). Επίσης, για κάθε πόλη, να υπολογίζει πόσες ημέρες η θερμοκρασία ήταν κατώτερη από την αντίστοιχη μέση.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες_2 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30,10] , Μέση[10] , Σύνολο
ΑΚΕΡΑΙΕΣ: i, j, Ημέρες ! Σύνολο Παρόραμα Σχολικού βιβλίου
ΑΡΧΗ ! Εισαγωγή δεδομένων 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 
        ΓΡΑΨΕ 'Δώσε τη θερμοκρασία', i, j 
        ΔΙΑΒΑΣΕ Θερμοκρασία[i,j] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
!Υπολογισμοί 
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 
    Σύνολο <-- 0 
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 
        Σύνολο <-- Σύνολο + Θερμοκρασία[i,j] 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
    Μέση[j] <-- Σύνολο/30 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 10 
    Ημέρες <-- 0 
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30 
       ΑΝ Θερμοκρασία[i,j] < Μέση[j] ΤΟΤΕ 
          Ημέρες <-- Ημέρες+1 
       ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Μέση Θερμοκρασία', i, 'Πόλης:', Μέση[j] 
ΓΡΑΨΕ 'Ημέρες με μικρότερη θερμοκρασία', Ημέρες 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This