Επιλογή Σελίδας

Για παράδειγμα ένα πρόγραμμα το οποίο διαβάζει τις θερμοκρασίες διαφόρων ημερών του μήνα, έστω 30, και υπολογίζει τη μέση θερμοκρασία, μπορεί πολύ απλά να γραφεί ως εξής:

ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες 
ΜΕΤΑΒΛΗΤΕΣ 
ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο  
ΑΚΕΡΑΙΕΣ: i, Ημέρες 
ΑΡΧΗ  
Σύνολο <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30  
    ΓΡΑΨΕ 'Δώσε τη θερμοκρασία'  
    ΔΙΑΒΑΣΕ Θερμοκρασία[i]   
    Σύνολο <-- Σύνολο+ Θερμοκρασία[i] 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ  
Μέση <-- Σύνολο/30  
Ημέρες <-- 0 
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30  
    ΑΝ Θερμοκρασία[i] < Μέση ΤΟΤΕ    
       Ημέρες <-- Ημέρες+1  
    ΤΕΛΟΣ_ΑΝ 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΓΡΑΨΕ 'Μέση Θερμοκρασία:', Μέση 
ΓΡΑΨΕ 'Ημέρες με μικρότερη θερμοκρασία', Ημέρες 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This