Επιλογή Σελίδας

Σύμφωνα με το διεθνές σύστημα ονοματολογίας της IUPAC, το όνομα ενός άκυκλου υδρογονάνθρακα CxHy με ευθύγραμμη ανθρακική αλυσίδα αποτελείται από τρία συνθετικά. Το πρώτο συνθετικό (σ1) καθορίζεται από τον αριθμό x των ατόμων άνθρακα, ως εξής: Όταν x=1, η τιμή του σ1 είναι μεθ· όταν   x=2, η τιμή του σ1 είναι αιθ· όταν x=3, η τιμή του σ1 είναι προπ· όταν x=4, η τιμή του σ1 είναι βουτ· όταν x=5, η τιμή του σ1 είναι πεντ· όταν x=6, η τιμή του σ1 είναι εξ κ.ο.κ. Το δεύτερο συνθετικό (σ2) εξαρτάται από τον αριθμό x των ατόμων του άνθρακα και από τον αριθμό y των ατόμων υδρογόνου και η τιμή του είναι σ2=άν ή σ2 = έν ή σ2=ίν ή σ2=αδιέν, σύμφωνα με τις συνθήκες που φαίνονται στον Πίνακα II.

Τιμή  του  σ2 Συνθήκη
άν y=2x+2, x≥1
έν y=2x, x≥2
ίν y=2x-2, x≥2
αδιέν y=2x-2, x≥3

Πίνακας  ΙΙ

Το τρίτο συνθετικό (σ3) είναι σε κάθε περίπτωση η κατάληξη ιο.
Όπως φαίνεται στον Πίνακα II, όταν x≥3, η τιμή του σ2 είναι ίν ή αδιέν. Ο τρόπος καθορισμού του ορθού ονόματος της ένωσης στην περίπτωση αυτή δεν μας ενδιαφέρει στο πλαίσιο της άσκησης.
Για παράδειγμα, όταν x=3 και y=8, η ένωση είναι το προπάνιο, ενώ αν x=3 και y=4, η ένωση είναι το προπίνιο ή το προπαδιένιο.
Να κατασκευάσετε αλγόριθμο ο οποίος:
Γ1. Να ζητάει τον αριθμό ατόμων άνθρακα της χημικής ένωσης, κάνοντας έλεγχο εγκυρότητας ώστε αυτός να είναι θετικός.
Μονάδες 2
Γ2. Να ζητάει τον αριθμό ατόμων υδρογόνου της χημικής ένωσης, κάνοντας έλεγχο εγκυρότητας ώστε να ικανοποιείται τουλάχιστον μία από τις συνθήκες του Πίνακα II.
Μονάδες 6
Γ3.   Να εκχωρεί στις μεταβλητές
σ1: το πρώτο συνθετικό του ονόματος της χημικής ένωσης. Θεωρείστε ότι δίνεται πίνακας Π, σε διαδοχικές θέσεις του οποίου βρίσκονται ήδη καταχωρισμένα τα λεκτικά που αντιστοιχούν στον αριθμό των ατόμων του άνθρακα (μονάδες 2) και
σ3: την κατάληξη του ονόματος της χημικής ένωσης (μονάδες 2).
Μονάδες 4
Γ4. Να υπολογίζει το σ2 και να εμφανίζει το όνομα (ή τα ονόματα) της χημικής ένωσης, εμφανίζοντας τα τρία συνθετικά, το ένα δίπλα στο άλλο, χωρισμένα με το χαρακτήρα «».
Μονάδες 8

Τα θέματα σε pdf, 2015, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

ΘΕΜΑΓ_2015ΕΠΑΝ_ΗΜΕΡ [δεδομένα]

 

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2015_ΕΠΑΝ_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: x, y , i
 ΧΑΡΑΚΤΗΡΕΣ: σ1, σ2, σ2β, σ3, Π[10]
 ΛΟΓΙΚΕΣ: Με_2_Ονόματα 

ΑΡΧΗ 
 ! Για τις ανάγκες του προγράμματος
 ΓΙΑ i από 1 μέχρι 10
     Διάβασε Π[i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


 ! Γ1
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΑΡΙΘΜΟ ΑΤΟΜΩΝ ΑΝΘΡΑΚΑ (C):' 
    ΔΙΑΒΑΣΕ x
 ΜΕΧΡΙΣ_ΟΤΟΥ x > 0 

 ! Γ2
 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΤΕ ΑΡΙΘΜΟ ΑΤΟΜΩΝ ΥΔΡΟΓΟΝΟΥ (H):'
    ΔΙΑΒΑΣΕ y 
 ΜΕΧΡΙΣ_ΟΤΟΥ (y >= 2*x+2 ΚΑΙ x>=1) Ή (y >= 2*x-2 ΚΑΙ x >= 2)

 ! Γ3
 σ1 <-- Π[x]
 σ3 <-- 'ιο'

 ! Γ4
 Με_2_Ονόματα <-- ΨΕΥΔΗΣ
 ΑΝ y = 2*x+2 ΤΟΤΕ
    σ2 <-- 'άν' 
 ΑΛΛΙΩΣ_ΑΝ y = 2*x ΤΟΤΕ 
    σ2 <-- 'έν'
 ΑΛΛΙΩΣ_ΑΝ y = 2*x-2 ΤΟΤΕ 
    σ2 <-- 'ίν'
    ΑΝ x>=3 ΤΟΤΕ
       Με_2_Ονόματα <-- ΑΛΗΘΗΣ
       σ2β <-- 'αδιέν'
    ΤΕΛΟΣ_ΑΝ 
 ΤΕΛΟΣ_ΑΝ

 ΓΡΑΨΕ σ1, '-', σ2, '-', σ3
 ΑΝ Με_2_Ονόματα = ΑΛΗΘΗΣ ΤΟΤΕ 
    ΓΡΑΨΕ σ1, '-', σ2β, '-', σ3
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 
Share This