Επιλογή Σελίδας

Μία εταιρεία αποφάσισε να δώσει βοηθητικό επίδομα στους υπαλλήλους της για τον μήνα Ιούλιο. Το επίδομα διαφοροποιείται, ανάλογα με το φύλο του/της υπαλλήλου και τον αριθμό των παιδιών του/της, με βάση τους παρακάτω πίνακες:

ΑΝΔΡΕΣ
ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ ΕΠΙΔΟΜΑ ΣΕ €
1 20
2 50
>=3 120

 

ΓΥΝΑΙΚΕΣ
ΑΡΙΘΜΟΣ ΠΑΙΔΙΩΝ ΕΠΙΔΟΜΑ ΣΕ €
1 30
2 80
>=3 160

Να γράψετε αλγόριθμο ο οποίος

α. διαβάζει το φύλο («Α» ή «Γ») το οποίο ελέγχεται ως προς την ορθότητα της εισαγωγής του. Επίσης διαβάζει τον μισθό και τον αριθμό των παιδιών του υπαλλήλου.

Μονάδες 3

β. υπολογίζει και εμφανίζει το επίδομα και το συνολικό ποσό που θα εισπράξει ο υπάλληλος τον μήνα Ιούλιο.

Μονάδες 7

γ. δέχεται απάντηση «ΝΑΙ» ή «ΟΧΙ» για τη συνέχεια ή τον τερματισμό της επανάληψης μετά την εμφάνιση σχετικού μηνύματος.

Μονάδες 4

δ. υπολογίζει και εμφανίζει το συνολικό ποσό επιδόματος που πρέπει να καταβάλει η Εταιρεία στους υπαλλήλους της.

Μονάδες 6

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ  ΗΜ_2008_07_3
 ΜΕΤΑΒΛΗΤΕΣ
   ΑΚΕΡΑΙΕΣ : s , n , x
   ΠΡΑΓΜΑΤΙΚΕΣ : pay
   ΧΑΡΑΚΤΗΡΕΣ : gender , answer
 ΑΡΧΗ
 
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
 
     ΓΡΑΨΕ 'Δώσε το φύλο του/της υπαλλήλου (Α ή Γ)'
     ΔΙΑΒΑΣΕ gender                                          
     ΟΣΟ gender <> 'Α' ΚΑΙ gender <> 'Γ' ΕΠΑΝΑΛΑΒΕ
       ΓΡΑΨΕ 'Λάθος. Ξαναδώσε.'
       ΔΙΑΒΑΣΕ gender
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
     ΓΡΑΨΕ 'Δώσε το μισθό που παίρνει.'
     ΔΙΑΒΑΣΕ pay
 
     ΓΡΑΨΕ 'Πόσα παιδιά έχει;'
     ΔΙΑΒΑΣΕ n
 
     ΑΝ gender = 'Α' ΤΟΤΕ
       ΑΝ n = 1 ΤΟΤΕ
         x <-- 20
       ΑΛΛΙΩΣ_ΑΝ n = 2 ΤΟΤΕ
         x <-- 50
       ΑΛΛΙΩΣ
         x <-- 120
       ΤΕΛΟΣ_ΑΝ
     ΑΛΛΙΩΣ
       ΑΝ n = 1 ΤΟΤΕ
         x <-- 30
       ΑΛΛΙΩΣ_ΑΝ n = 2 ΤΟΤΕ
         x <-- 80
       ΑΛΛΙΩΣ
         x <-- 160
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΑΝ
 
     ΓΡΑΨΕ 'Επίδομα υπαλλήλου =' , x
     ΓΡΑΨΕ 'Συνολικό ποσό προς είσπραξη =' , pay+x
 
     s <-- s + x
 
     ΓΡΑΨΕ 'Υπάρχει και άλλος ή άλλη;'
     ΓΡΑΨΕ '     (ΝΑΙ ή ΟΧΙ)'
     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
       ΔΙΑΒΑΣΕ answer
     ΜΕΧΡΙΣ_ΟΤΟΥ answer = 'ΝΑΙ' ή answer = 'ΟΧΙ'
 
   ΜΕΧΡΙΣ_ΟΤΟΥ answer = 'ΟΧΙ'
 
   ΓΡΑΨΕ 'Συνολικό ποσό επιδομάτων =' , s
 
 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Από Ασκησιολόγιο ΓλωσσοΜάθειας

Share This