Επιλογή Σελίδας

Εταιρεία που ασχολείται με μετρήσεις τηλεθέασης καταγράφει στοιχεία, ανά ημέρα και για χρονικό διάστημα μίας εβδομάδας, τα οποία αφορού την τηλεθέαση   των κεντρικών δελτίων ειδήσεων που  προβάλλονται από πέντε (5) τηλεοπτικούς σταθμούς.
Για τη διευκόλυνση της στατιστικής επεξεργασίας των δεδομένων να αναπτύξετε πρόγραμμα το οποίο:

Δ1.  Να περιλαμβάνει τμήμα δηλώσεων.
Μονάδες 2
Δ2. Για κάθε έναν από τους τηλεοπτικούς σταθμούς να δέχεται το όνομά του και το πλήθος των τηλεθεατών που παρακολούθησαν το κεντρικό δελτίο ειδήσεων κάθε μέρα της εβδομάδας, από Δευτέρα έως και Κυριακή. Να μη γίνει έλεγχος εγκυρότητας.
Μονάδες 4
Δ3.
Να καλεί για κάθε έναν από τους τηλεοπτικούς σταθμούς κατάλληλο υποπρόγραμμα, το οποίο να υπολογίζει και να επιστρέφει το μέσο πλήθος τηλεθεατών, που παρακολούθησαν το κεντρικό δελτίο ειδήσεών του, τη συγκεκριμένη εβδομάδα. Να αναπτύξετε το κατάλληλο υποπρόγραμμα.
Μονάδες 4
Δ4.  Να εμφανίζει τα ονόματα των σταθμών για τους οποίους ο μέσος όρος τηλεθέασης του Σαββατοκύριακου (2 ημέρες) ήταν  τουλάχιστον  10% μεγαλύτερος από το μέσο όρο τηλεθέασης στις καθημερινές (Δευτέρα έως και Παρασκευή).
Μονάδες 5
Δ5.
Να εμφανίζει τα ονόματα των τηλεοπτικών σταθμών, οι οποίοι κάθε ημέρα, από Δευτέρα έως και Κυριακή, παρουσιάζουν συνεχώς, από ημέρα σε ημέρα, αύξηση τηλεθέασης. Αν δεν υπάρχουν τέτοιοι σταθμοί, να εμφανίζει το μήνυμα: «Κανένας σταθμός δεν είχε συνεχή αύξηση τηλεθέασης».
Μονάδες 5

Τα θέματα σε pdf, 2012, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ  ΘΕΜΑ_Δ_2012_ΕΠΑΝ_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, ΤΗΛ[7,5], S5, S2
  ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ[5], ΜΟ5, ΜΟ2
  ΛΟΓΙΚΕΣ: βρέθηκε, Αύξηση_τηλεθέασης
ΑΡΧΗ
! Δ2
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
    ΓΡΑΨΕ 'ΗΜΕΡΑ ', i
    ΓΙΑ  j ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ 'ΤΗΛΕΘΕΑΤΕΣ ΣΤΑΘΜΟΥ ', j
      ΔΙΑΒΑΣΕ ΤΗΛ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ3
  ΓΙΑ  j ΑΠΟ 1 ΜΕΧΡΙ 5
    ΜΟ[j] <-- MΟ_τηλεθ_εβδομάδας(ΤΗΛ, j)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ4
  ΓΡΑΨΕ 'ΣΤΑΘΜΟΙ ΜΕ 10% ΠΕΡΙΣΣΟΤΕΡΗ ΤΗΛΕΘΕΑΣΗ ΤΟ ΣΚ:'
  ΓΙΑ  j ΑΠΟ 1 ΜΕΧΡΙ 5
    ! MO Καθημερινών
    S5 <-- 0
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
      S5 <-- S5 + ΤΗΛ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ5 <-- S5 / 5

    ! MO Σαββάτου Κυριακής
    S2 <-- 0
    ΓΙΑ  i ΑΠΟ 6 ΜΕΧΡΙ 7
      S2 <-- S2 + ΤΗΛ[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΜΟ2 <-- S2 / 2

    ΑΝ ΜΟ2 >= 1.1 * ΜΟ5 ΤΟΤΕ  ! 10% μεγαλύτερο του ΜΟ5 (1 + 10/100)
      ΓΡΑΨΕ 'ΣΤΑΘΜΟΣ ', j
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ5
  βρέθηκε <-- ΨΕΥΔΗΣ
  ΓΙΑ  j ΑΠΟ 1 ΜΕΧΡΙ 5
    Αύξηση_τηλεθέασης <-- ΑΛΗΘΗΣ
    i <-- 1
    ΟΣΟ i<=6 ΚΑΙ Αύξηση_τηλεθέασης=ΑΛΗΘΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ ΤΗΛ[i+1,j] > ΤΗΛ[i,j] ΤΟΤΕ
        i <-- i + 1
      ΑΛΛΙΩΣ
        Αύξηση_τηλεθέασης <-- ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ Αύξηση_τηλεθέασης=ΑΛΗΘΗΣ ΤΟΤΕ
      ΓΡΑΨΕ 'ΣΤΑΘΜΟΣ ΜΕ ΣΥΝΕΧΗ ΑΥΞΗΣΗ ΤΗΛΕΘΕΑΣΗΣ ', j
      ΑΝ βρεθηκε = ΨΕΥΔΗΣ ΤΟΤΕ
        βρέθηκε <-- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ βρεθηκε = ΨΕΥΔΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Κανένας σταθμός δεν είχε συνεχή αύξηση τηλεθέασης'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ MΟ_τηλεθ_εβδομάδας(τηλεθέαση, σταθμός): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: τηλεθέαση[7,5], j, S, μέρα, σταθμός
ΑΡΧΗ
  S <-- 0
  ΓΙΑ μέρα ΑΠΟ 1 ΜΕΧΡΙ 7
    S <-- S + τηλεθέαση[μέρα, σταθμός]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  MΟ_Τηλεθ_εβδομάδας <-- S / 7
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This