Επιλογή Σελίδας

Δίνεται πίνακας Π[20] με αριθμητικές τιμές. Στις μονές θέσεις βρίσκονται καταχωρισμένοι θετικοί αριθμοί και στις ζυγές αρνητικοί αριθμοί. Επίσης, δίνεται το παρακάτω τμήμα αλγορίθμου ταξινόμησης τιμών του πίνακα.

Για x από 3 μέχρι 19 με_βήμα ______ 
    Για y από ______ μέχρι________ με_βήμα _________ 
       Αν Π[________ ] < Π[________ ] Τότε
          Αντιμετάθεσε Π[________ ], Π[_________ ]
       Τέλος_αν
    Τέλος_Επανάληψης
Τέλος_Επανάληψης

Να μεταφέρετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου συμπληρώνοντας τα κενά με τις κατάλληλες σταθερές, μεταβλητές ή εκφράσεις, ώστε να ταξινομούνται σε αύξουσα σειρά μόνο οι θετικές τιμές του πίνακα.

Μονάδες 8

ΛΥΣΗ

Για x από 3 μέχρι 19 με_βήμα 2
    Για y από 19 μέχρι x με_βήμα -2
    Αν Π[y] < Π[y-2] τότε
           Αντιμετάθεσε Π[y] ,Π[y-2]
        Τέλος_αν
    Τέλος_επανάληψης
Τέλος_επανάληψης
Share This