Επιλογή Σελίδας

Δίνονται τα παρακάτω τμήματα αλγορίθμου σε φυσική γλώσσα.

  1. Αν η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από τον Μέσο Όρο (ΜΟ), τότε να τυπώνει «Πολύ Καλά», αν είναι ίση ή μικρότερη του Μέσου Όρου μέχρι και δύο μονάδες να τυπώνει «Καλά», σε κάθε άλλη περίπτωση να τυπώνει «Μέτρια».
  2. Αν το τμήμα (ΤΜΗΜΑ) είναι το Γ1 και η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από 15, τότε να τυπώνει το επώνυμο (ΕΠΩΝΥΜΟ).
  3. Αν η απάντηση (ΑΠΑΝΤΗΣΗ) δεν είναι Ν ή ν ή Ο ή ο, τότε να τυπώνει «Λάθος απάντηση».
  4. Αν ο αριθμός (Χ) είναι αρνητικός ή το ημίτονό του είναι μηδέν, τότε να τυπώνει «Λάθος δεδομένο», αλλιώς να υπολογίζει και να τυπώνει την τιμή της   παράστασης 1-2-2010-imerisia-maiou-aepp_2010_imerisia

Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως 4 και δίπλα σε κάθε αριθμό την αντίστοιχη κωδικοποίηση σε ΓΛΩΣΣΑ.

Σημείωση:   Οι   λέξεις   με   κεφαλαία   μέσα   στις   παρενθέσεις είναι τα ονόματα των αντίστοιχων μεταβλητών.

Μονάδες 8

ΛΥΣΗ

1.Αν ΒΑΘΜΟΣ>ΜΟ τότε 
     Γράψε 'ΠΟΛΥ ΚΑΛΑ'
  αλλιώς_αν ΜΟ-ΒΑΘΜΟΣ<=2 τότε 
        Γράψε 'ΚΑΛΑ'         
  αλλιώς 
        Γράψε 'ΜΕΤΡΙΑ' 
  Τέλος_αν
2.Αν ΤΜΗΜΑ='Γ1' και ΒΑΘΜΟΣ>15 τότε
     Γράψε ΕΠΩΝΥΜΟ     
  Τέλος_αν
3.Αν ΑΠΑΝΤΗΣΗ<>'Ν' και ΑΠΑΝΤΗΣΗ<>'Ο' και ΑΠΑΝΤΗΣΗ<>'ν' και ΑΠΑΝΤΗΣΗ<>'ο' τότε
     Γράψε 'ΛΑΘΟΣ ΑΠΑΝΤΗΣΗ'
  Τέλος_αν
4.Αν x<0 ή ΗΜ(x)=0 τότε
     Γράψε 'ΛΑΘΟΣ ΔΕΔΟΜΕΝΟ' 
  αλλιώς 
     Γράψε (x^2+5*x+1)/(T_Ρ(x)* ΗΜ(x)) 
  Τέλος_αν
Share This