Επιλογή Σελίδας

Ο λογαριασμός του νερού είναι τριμηνιαίος και υπολογίζεται με βάση την κατανάλωση νερού. Η αξία του νερού υπολογίζεται από τον παρακάτω πίνακα.

Στην αξία του νερού προστίθεται το πάγιο (έστω 1,47€), η αποχέτευση 40% της αξίας του νερού, άλλες επιβαρύνσεις 1% καθώς και το ΦΠΑ που είναι 18% στο σύνολο του λογαριασμού. Να γραφεί πρόγραμμα που διαβάζει το ονοματεπώνυμο του καταναλωτή, τον αριθμό του μετρητή νερού, την κατανάλωση (ανά τρίμηνο) και να υπολογίζει και να τυπώνει τα ποσά του λογαριασμού. Η διαδικασία επαναλαμβάνεται συνεχώς για διάφορους καταναλωτές και τερματίζεται με την είσοδο του 0 ως αριθμού μετρητή.

ΛΥΣΗ

Παραθέτουμε τη λύση του, μέ τη χρήση ΑΛΛΙΩΣ ΑΝ (αντί της ΕΠΙΛΕΞΕ)

ΠΡΟΓΡΑΜΜΑ ΛΟΓΑΡΙΑΣΜΟΣ_ΝΕΡΟΥ 
ΣΤΑΘΕΡΕΣ 
ΦΠΑ=0.18 
ΤΙΜΗ1=0,34 
ΤΙΜΗ2=0,52 
ΤΙΜΗ3=1,51 
ΤΙΜΗ4=2,11 
ΤΙΜΗ5=2,64 
ΠΑΓΙΟ=1,47 
ΜΕΤΑΒΛΗΤΕΣ 
ΑΚΕΡΑΙΕΣ: Μετρητής 
ΠΡΑΓΜΑΤΙΚΕΣ: Κατανάλωση, Τιμή, Αποχέτευση, Άλλα, Αξία_ΦΠΑ, Αξία, & Τελική_Τιμή 
ΧΑΡΑΚΤΗΡΕΣ: Όνομα, Επώνυμο 
ΑΡΧΗ 
ΓΡΑΨΕ 'Δώσε Αριθμό του μετρητή (0 για τέλος)' 
ΔΙΑΒΑΣΕ Μετρητής 
ΟΣΟ Μετρητής <> 0 ΕΠΑΝΑΛΑΒΕ 
    ΓΡΑΨΕ 'Δώσε το Ονοματεπώνυμο'
    ΔΙΑΒΑΣΕ Επώνυμο, Όνομα 
    ΓΡΑΨΕ 'Δώσε την Κατανάλωση' 
    ΔΙΑΒΑΣΕ Κατανάλωση 
    ΑΝ Κατανάλωση <= 15 ΤΟΤΕ
       Αξία <- Κατανάλωση*ΤΙΜΗ1 
    ΑΛΛΙΩΣ_ΑΝ Κατανάλωση <= 60 ΤΟΤΕ 
          Αξία <- 15*ΤΙΜΗ1 + (Κατανάλωση-15)*ΤΙΜΗ2 
    ΑΛΛΙΩΣ_ΑΝ Κατανάλωση <= 81 ΤΟΤΕ 
          Αξία <- 15*ΤΙΜΗ1 + 45*ΤΙΜΗ2 + (Κατανάλωση-60)*ΤΙΜΗ3 
    ΑΛΛΙΩΣ_ΑΝ Κατανάλωση <= 105 ΤΟΤΕ 
          Αξία <- 15*ΤΙΜΗ1 + 45*ΤΙΜΗ2 + 21*ΤΙΜΗ3 + (Κατανάλωση-81)*ΤΙΜΗ4 
    ΑΛΛΙΩΣ 
       Αξία <- 15*ΤΙΜΗ1+45*ΤΙΜΗ2+21*ΤΙΜΗ3+24*ΤΙΜΗ4+(Κατανάλωση-105)*ΤΙΜΗ5 
    ΤΕΛΟΣ_ΑΝ 
    Αποχέτευση <- Αξία*0.4 
    Άλλα <- Αξία*0.01 Τιμή <- Αξία+ Αποχέτευση+ Άλλα+ ΠΑΓΙΟ 
    Αξία_ΦΠΑ <- Τιμή* ΦΠΑ Τελική_τιμή <- Τιμή + Αξία_ΦΠΑ 
    ΓΡΑΨΕ 'Ο λογαριασμός του', Επώνυμο,' είναι ', Τελική_τιμή 
    ΓΡΑΨΕ 'Αξία νερού:', Αξία ΓΡΑΨΕ 'άλλα:', Αποχέτευση+ Άλλα, 'ΦΠΑ:', Αξία_ΦΠΑ 
    ΓΡΑΨΕ 'Δώσε Αριθμό του επόμενου μετρητή (0 για τέλος)' 
    ΔΙΑΒΑΣΕ Μετρητής 
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This