Να υλοποιηθεί πρόγραμμα που θα διαβάζει το ύψος των μαθητών των τάξεων του σχολείου. Αρχικά θα διαβάζει και θα εκτυπώνει το τμήμα, κατόπιν θα διαβάζει το ύψος μαθητών μέχρι να διαβαστεί η τιμή 0. Για κάθε τμήμα υπολογίζεται και εμφανίζεται ο ΜΟ όρος ύψους των μαθητών.
Το διάβασμα των τμημάτων σταματά όταν διαβαστεί διαβαστεί η τιμή ΤΕΛΟΣ.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΕΠΑΝΑΛΗΠΤΙΚΗ_ΟΣΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  sum, μαθητές,
ΠΡΑΓΜΑΤΙΚΕΣ: mo 
ΑΡΧΗ
!για ένα τμήμα 

μαθητές ← 0 ! μετρητής του αριθμού των μαθητών
sum ← 0         ! άθροισμα του ύψους όλων μαθητών του τμήματος
  ΔΙΑΒΑΣΕ ΥΨΟΣ  ! 1 ΔΙΑΒΑΣΜΑ ΕΞΩ ΑΠΟ ΤΗΝ ΕΠΑΝΑΛΗΨΗ
  ΟΣΟ ΥΨΟΣ <> 0 ΕΠΑΝΑΛΑΒΕ
 sum ← sum + ΥΨΟΣ
μαθητες ← μάθητες + 1
    ΔΙΑΒΑΣΕ ΥΨΟΣ   ! 1 ΔΙΑΒΑΣΜΑ ΣΤΟ ΤΕΛΟΣ ΤΗΣ ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
mo ← sum / μαθητές ! μέσος όρος του ύψους των μαθητών του τμήματος
ΓΡΑΨΕ mo
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

προέκταση:

ΠΡΟΓΡΑΜΜΑ ΕΠΑΝΑΛΗΠΤΙΚΗ_ΟΣΟ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:  sum, μαθητές, ΤΜΗΜΑ
ΠΡΑΓΜΑΤΙΚΕΣ: mo 
ΑΡΧΗ
ΔΙΑΒΑΣΕ ΤΜΗΜΑ  ! 1 ΔΙΑΒΑΣΜΑ ΕΞΩ ΑΠΟ ΤΗΝ ΕΠΑΝΑΛΗΨΗ
ΓΡΑΨΕ ΤΜΗΜΑ
ΟΣΟ ΤΜΗΜΑ <> ΤΕΛΟΣ ΕΠΑΝΑΛΑΒΕ
!για ένα τμήμα 
    μαθητές ← 0 ! μετρητής του αριθμού των μαθητών
    sum ← 0         ! άθροισμα του ύψους όλων μαθητών του τμήματος
    ΔΙΑΒΑΣΕ ΥΨΟΣ  ! 1 ΔΙΑΒΑΣΜΑ ΕΞΩ ΑΠΟ ΤΗΝ ΕΠΑΝΑΛΗΨΗ
    ΟΣΟ ΥΨΟΣ <> 0 ΕΠΑΝΑΛΑΒΕ
        sum ← sum + ΥΨΟΣ
        μαθητες ← μάθητες + 1
        ΔΙΑΒΑΣΕ ΥΨΟΣ   ! 1 ΔΙΑΒΑΣΜΑ ΣΤΟ ΤΕΛΟΣ ΤΗΣ ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    mo ← sum / μαθητές ! μέσος όρος του ύψους των μαθητών του τμήματος
    ΓΡΑΨΕ mo
    ΔΙΑΒΑΣΕ ΤΜΗΜΑ   ! 1 ΔΙΑΒΑΣΜΑ ΣΤΟ ΤΕΛΟΣ ΤΗΣ ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This