Επιλογή Σελίδας

Δίνεται παρακάτω ένα πρόγραμμα με ένα υποπρόγραμμα:

ΠΡΟΓΡΑΜΜΑ Υπολογισμοί

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ

ΑΡΧΗ

ΔΙΑΒΑΣΕ α, β

γ <- α + Πράξη (α, β)

ΓΡΑΨΕ γ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ Πράξη (χ, ψ): ΠΡΑΓΜΑΤΙΚΗ

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ

ΑΡΧΗ

ΑΝ χ >= ψ ΤΟΤΕ

Πράξη <- χ – ψ ΑΛΛΙΩΣ

Πράξη <- χ + ψ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

α. Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί συνάρτησης.

Μονάδες 7

β. Να ξαναγράψετε το πρόγραμμα που δόθηκε αρχικά, ώστε να επιτελεί την ίδια λειτουργία χωρίς τη χρήση υποπρογράμματος.

Μονάδες 7

γ.    Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν    κατά την εκτέλεση του αρχικού προγράμματος που δόθηκε,   αν   ως τιμές εισόδου δοθούν οι αριθμοί:

  1. α = 10 β = 5
  2. α = 5   β = 5
  3. α = 3   β = 5

Μονάδες 6

Τα θέματα σε pdf, 2007, Μαΐου-Ιουνίου, Ημερήσια

Share This