ΘΕΜΑ Γ
Μια συνεταιριστική γεωργική μονάδα επεξεργάζεται στο αποστακτήριό της ένα ελληνικό αρωματικό φυτό και παράγει αιθέριο έλαιο. Στο αποστακτήριο εισάγονται δέματα και κάθε δέμα ζυγίζεται. Το βάρος κάθε δέματος εισάγεται σε ένα πληροφοριακό σύστημα. Μετά την απόσταξη κάθε δέματος το αιθέριο έλαιο που παράγεται ζυγίζεται και το βάρος του εισάγεται επίσης στο πληροφοριακό σύστημα. Μετά το τέλος της παραγωγής το αιθέριο έλαιο συσκευάζεται σε φιαλίδια που περιέχουν 2 γραμμάρια προϊόντος το καθένα.
Να αναπτύξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
Γ1.α. να περιέχει κατάλληλο τμήμα δηλώσεων, (μονάδες 2)
β. να διαβάζει το βάρος κάθε δέματος σε κιλά και το βάρος του παραγόμενου αιθέριου ελαίου σε γραμμάρια (πραγματικοί αριθμοί). Η εισαγωγή δεδομένων να τερματίζεται όταν στο ερώτημα:
Θα συνεχιστεί η εισαγωγή; ΝΑΙ/ΟΧΙ
η απάντηση είναι ΟΧΙ ή όταν ως βάρος του παραχθέντος αιθέριου ελαίου δοθεί η τιμή 0. (μονάδες 4)
Μονάδες 6
Γ2. Να υπολογίζει και να εμφανίζει με κατάλληλα μηνύματα το πλήθος των δεμάτων που εισήχθησαν και το συνολικό βάρος του αιθέριου ελαίου που παρήχθη.
Μονάδες 4
Γ3. Να βρίσκει και να εμφανίζει τη σειρά εισαγωγής που είχε το δέμα εκείνο από το οποίο παρήχθη η μεγαλύτερη ποσότητα αιθέριου ελαίου (να θεωρήσετε ότι το δέμα αυτό είναι μοναδικό).
Μονάδες 4
Γ4. Να υπολογίζει και να εμφανίζει τον συνολικό αριθμό φιαλιδίων που γέμισαν.
Μονάδες 2
Γ5. Να υπολογίζει και να εμφανίζει τον μέγιστο αριθμό διαδοχικών δεμάτων από τα οποία παρήχθη η ίδια ποσότητα αιθέριου ελαίου.(Να θεωρήσετε ότι υπάρχουν δύο τουλάχιστον τέτοια διαδοχικά δέματα). Μονάδες 4
(Να θεωρήσετε ότι δεν απαιτείται έλεγχος εγκυρότητας για τις τιμές εισόδου).

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ_2018_ΕΠΑΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΔΕΜΑΤΑ, ΣΕΙΡΑ, ΔΙΑΔΟΧΙΚΑ, ΜΑΧ_ΔΙΑΔ, ΦΙΑΛΙΔΙΑ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΡΟΣ_Δ, ΒΑΡΟΣ_Ε, ΣΥΝ_ΒΑΡΟΣ_Ε, ΠΡΟΗΓ_ΒΑΡΟΣ_Ε, ΜΑΧ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠΑΝΤΗΣΗ
ΑΡΧΗ
  ΔΙΑΔΟΧΙΚΑ <- 1                                                             !Γ5
  ΜΑΧ_ΔΙΑΔ <- 1                                                              !Γ5
  ΠΡΟΗΓ_ΒΑΡΟΣ_Ε <- -999                                                      !Γ5
  ΜΑΧ <- -999                                                                !Γ3
  ΣΕΙΡΑ <- 0                                                                 !Γ3
  ΔΕΜΑΤΑ <- 0                                                                !Γ2
  ΣΥΝ_ΒΑΡΟΣ_Ε <- 0                                                           !Γ2

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ                                                           !Γ1Β
    ΔΙΑΒΑΣΕ ΒΑΡΟΣ_Δ, ΒΑΡΟΣ_Ε
    ΓΡΑΨΕ 'Θα συνεχιστεί η εισαγωγή; ΝΑΙ/ΟΧΙ'                               !Γ1Β
    ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ
    ΑΝ ΒΑΡΟΣ_Ε <> 0 ΤΟΤΕ                                                    !Γ1Β
      ΣΥΝ_ΒΑΡΟΣ_Ε <- ΣΥΝ_ΒΑΡΟΣ_Ε + ΒΑΡΟΣ_Ε                                   !Γ2
      ΔΕΜΑΤΑ <- ΔΕΜΑΤΑ + 1                                                   !Γ2
      ΑΝ ΜΑΧ < ΒΑΡΟΣ_Ε ΤΟΤΕ                                                  !Γ3
        ΜΑΧ <- ΒΑΡΟΣ_Ε
        ΣΕΙΡΑ <- ΔΕΜΑΤΑ
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ΒΑΡΟΣ_Ε = ΠΡΟΗΓ_ΒΑΡΟΣ_Ε ΤΟΤΕ                                       ! Γ5
        ΔΙΑΔΟΧΙΚΑ <- ΔΙΑΔΟΧΙΚΑ + 1
        ΑΝ ΜΑΧ_ΔΙΑΔ < ΔΙΑΔΟΧΙΚΑ ΤΟΤΕ
          ΜΑΧ_ΔΙΑΔ <- ΔΙΑΔΟΧΙΚΑ
        ΤΕΛΟΣ_ΑΝ
      ΑΛΛΙΩΣ
        ΔΙΑΔΟΧΙΚΑ <- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    ΠΡΟΗΓ_ΒΑΡΟΣ_Ε <- ΒΑΡΟΣ_Ε                                                 !Γ5
  ΜΕΧΡΙΣ_ΟΤΟΥ ΒΑΡΟΣ_Ε = 0 Η ΑΠΑΝΤΗΣΗ = 'ΟΧΙ'                                !Γ1Β
  ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΔΕΜΑΤΩΝ ', ΔΕΜΑΤΑ                                 !Γ2
  ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΟ ΒΑΡΟΣ ΕΛΑΙΟΥ ', ΣΥΝ_ΒΑΡΟΣ_Ε                                !Γ2
  ΓΡΑΨΕ 'ΣΕΙΡΑ ΔΕΜΑΤΟΣ ΠΟΥ ΠΑΡΗΓΑΓΕ ΤΟ ΠΕΡΙΣΣΌΤΕΡΟ ΕΛΑΙΟ ', ΣΕΙΡΑ            !Γ3
  ΓΡΑΨΕ 'ΜΕΓΙΣΤΗ ΣΕΙΡΑ ΔΙΑΔΟΧΙΚΩΝ ΙΔΙΩΝ ΠΑΡΑΓΩΓΩΝ ', ΜΑΧ_ΔΙΑΔ
  ΦΙΑΛΙΔΙΑ <- Α_Μ(ΣΥΝ_ΒΑΡΟΣ_Ε/ 2)                                            !Γ4
  ΓΡΑΨΕ 'ΦΙΑΛΙΔΙΑ ΕΛΑΙΟΥ ', ΦΙΑΛΙΔΙΑ                                         !Γ4
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ</code class="language-javascript">
Share This