Επιλογή Σελίδας

Ένας πελάτης αγοράζει προϊόντα από ένα κατάστημα. Να αναπτύξετε αλγόριθμο ο οποίος:

Γ1. Για κάθε προϊόν που αγοράζει ο πελάτης, να διαβάζει τον κωδικό του, τον αριθμό τεμαχίων που αγοράστηκαν και την τιμή τεμαχίου. Η διαδικασία ανάγνωσης να σταματά, όταν δοθεί ως κωδικός ο αριθμός 0.
Μονάδες 3

Γ2. Αν ο λογαριασμός δεν υπερβαίνει τα 500 ευρώ, να εμφανίζει το μήνυμα «ΠΛΗΡΩΜΗ ΜΕΤΡΗΤΟΙΣ». Διαφορετικά, να υπολογίζει και να εμφανίζει το πλήθος των απαιτούμενων για την εξόφληση δόσεων, όταν η εξόφληση γίνεται με άτοκες μηνιαίες δόσεις, ως εξής: Τον πρώτο μήνα η δόση θα είναι 20 ευρώ και κάθε επόμενο μήνα θα αυξάνεται κατά 5 ευρώ, μέχρι να εξοφληθεί το συνολικό ποσό.
Μονάδες 6

Γ3. Να υπολογίζει και να εμφανίζει τον συνολικό αριθμό των τεμαχίων με τιμή τεμαχίου μεγαλύτερη των 10 ευρώ.
Μονάδες 5

Γ4. Να υπολογίζει και να εμφανίζει τον συνολικό αριθμό των τεμαχίων με τη μέγιστη τιμή τεμαχίου.
Μονάδες 6

Τα θέματα σε pdf, 2014, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ

ΘΕΜΑΓ_2014ΙΟΥΝ_ΗΜΕΡ [DEMO δεδομένα]

 

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2014_ΙΟΥΝ_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: ΤΕΜΑΧΙΑ, ΠΛΗΘΟΣ_ΤΕΜ, ΤΕΜ_ΜΑΧ_ΤΙΜΗΣ, i
 ΠΡΑΓΜΑΤΙΚΕΣ: ΤΙΜΗ, ΛΟΓΑΡΙΑΣΜΟΣ, ΜΑΧ_ΤΙΜΗ, ΠΟΣΟ_ΔΟΣΕΩΝ
 ΧΑΡΑΚΤΗΡΕΣ: ΚΩΔΙΚΟΣ
ΑΡΧΗ
 ! Αρχικοποίηση μεταβλητών
 ΛΟΓΑΡΙΑΣΜΟΣ <-- 0
 ΠΛΗΘΟΣ_ΤΕΜ <-- 0
 ΤΕΜ_ΜΑΧ_ΤΙΜΗΣ <-- 0
 ΜΑΧ_ΤΙΜΗ <-- 0

! Γ1
 ΓΡΑΨΕ 'ΔΩΣΤΕ ΚΩΔΙΚΟ ΠΡΟΙΟΝΤΟΣ:'
 ΔΙΑΒΑΣΕ ΚΩΔΙΚΟΣ
 ΟΣΟ ΚΩΔΙΚΟΣ <> '0' ΕΠΑΝΑΛΑΒΕ
     ΓΡΑΨΕ 'ΔΩΣΤΕ ΑΡΙΘΜΟ ΤΕΜΑΧΙΩΝ:'
     ΔΙΑΒΑΣΕ ΤΕΜΑΧΙΑ
     ΓΡΑΨΕ 'ΔΩΣΤΕ ΤΙΜΗ ΠΡΟΙΟΝΤΟΣ:'
     ΔΙΑΒΑΣΕ ΤΙΜΗ
     ΛΟΓΑΡΙΑΣΜΟΣ <-- ΛΟΓΑΡΙΑΣΜΟΣ + ΤΙΜΗ * ΤΕΜΑΧΙΑ

    ! Γ3
     ΑΝ ΤΙΜΗ > 10 ΤΟΤΕ
        ΠΛΗΘΟΣ_ΤΕΜ <-- ΠΛΗΘΟΣ_ΤΕΜ + ΤΕΜΑΧΙΑ
     ΤΕΛΟΣ_ΑΝ

    ! Γ4
    ΑΝ ΤΙΜΗ > ΜΑΧ_ΤΙΜΗ ΤΟΤΕ
       ΜΑΧ_ΤΙΜΗ <-- ΤΙΜΗ
       ΤΕΜ_ΜΑΧ_ΤΙΜΗΣ <-- ΤΕΜΑΧΙΑ
    ΑΛΛΙΩΣ_ΑΝ ΤΙΜΗ = ΜΑΧ_ΤΙΜΗ ΤΟΤΕ
       ΤΕΜ_ΜΑΧ_ΤΙΜΗΣ <-- ΤΕΜ_ΜΑΧ_ΤΙΜΗΣ + ΤΕΜΑΧΙΑ
    ΤΕΛΟΣ_ΑΝ

    ΓΡΑΨΕ 'ΔΩΣΤΕ ΚΩΔΙΚΟ ΠΡΟΙΟΝΤΟΣ:'
    ΔΙΑΒΑΣΕ ΚΩΔΙΚΟΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΤΕΜ ΚΟΣΤΟΥΣ > 10Ε:', ΠΛΗΘΟΣ_ΤΕΜ
ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΟΣ ΑΡΙΘΜΟΣ ΤΕΜ ΜΑΧ ΤΙΜΗΣ', ΤΕΜ_ΜΑΧ_ΤΙΜΗΣ

ΑΝ ΛΟΓΑΡΙΑΣΜΟΣ < 500 ΤΟΤΕ
   ΓΡΑΨΕ 'ΠΛΗΡΩΜΗ ΜΕΤΡΗΤΟΙΣ'
 ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'ΠΛΗΡΩΜΗ ΣΕ ΔΟΣΕΙΣ'
   ! Υπολογισμός δόσεων, α' τρόπος
   i <-- 1
   ΠΟΣΟ_ΔΟΣΕΩΝ <-- 20
   ΟΣΟ ΠΟΣΟ_ΔΟΣΕΩΝ < ΛΟΓΑΡΙΑΣΜΟΣ ΕΠΑΝΑΛΑΒΕ
! O υπολογισμός αυτός θα μπορούσε να γίνει σε 2 βήματα, πρώτα η δόση (20+i*5) και μετά η άθροιση στο σύνολο.
       ΠΟΣΟ_ΔΟΣΕΩΝ <-- ΠΟΣΟ_ΔΟΣΕΩΝ + (20+i*5) 
       i <-- i + 1
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ! θεωρούμε ότι η τελευταία δόση είναι το όποιο υπόλοιπο
   ΓΡΑΨΕ 'ΑΠΑΙΤΟΥΜΕΝΕΣ ΔΟΣΕΙΣ: ', i
 ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This