Επιλογή Σελίδας

Στις γενικές εξετάσεις, κάθε γραπτό βαθμολογείται από δύο βαθμολογητές στην κλίμακα 1-100. Όταν η διαφορά των δύο βαθμών είναι μεγαλύτερη από δώδεκα μονάδες, το γραπτό αναβαθμολογείται, δηλαδή βαθμολογείται και από τρίτο βαθμολογητή.

Στα γραπτά που δεν έχουν αναβαθμολογηθεί, ο τελικός βαθμός προκύπτει από το πηλίκο της διαίρεσης του αθροίσματος των βαθμών των δύο βαθμολογητών διά δέκα.

Στα γραπτά που έχουν αναβαθμολογηθεί, ο τελικός βαθμός προκύπτει με τον ίδιο τρόπο, αλλά λαμβάνονται υπόψη οι δύο μεγαλύτεροι βαθμοί.

Για στατιστικούς λόγους, οι τελικοί βαθμοί (ΤΒ) κατανέμονται στις παρακάτω βαθμολογικές κατηγορίες:

1η 2η 3η 4η 5η 6η
0≤ΤΒ<5 5≤ΤΒ<10 10≤ TΒ<12 12≤ΤΒ<15 15≤ΤΒ<18 18≤ΤΒ≤20

Σ’ ένα βαθμολογικό κέντρο υπάρχουν 780 γραπτά στο μάθημα «Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον».

Οι βαθμοί των δύο βαθμολογητών έχουν καταχωριστεί στις δύο πρώτες στήλες ενός πίνακα Β[780,3].

Να γραφεί αλγόριθμος ο οποίος:

Α. Να ελέγχει, για κάθε γραπτό, αν χρειάζεται αναβαθμολόγηση. Αν χρειάζεται, να ζητάει από τον χρήστη τον βαθμό του τρίτου βαθμολογητή και να τον εισάγει στην αντίστοιχη θέση της τρίτης στήλης, διαφορετικά να εισάγει την τιμή -1.

Δεν απαιτείται έλεγχος εγκυρότητας.

Μονάδες 4

Β. Να υπολογίζει τον τελικό βαθμό κάθε γραπτού και να τον καταχωρίζει στην αντίστοιχη θέση ενός πίνακα Τ[780].

Μονάδες 7

Γ.  Να εμφανίζει τη βαθμολογική κατηγορία (ή τις κατηγορίες) με το μεγαλύτερο πλήθος γραπτών.

Μονάδες 9

Τα θέματα σε pdf, 2009, Επαναληπτικές, Ημερήσια

ΛΥΣΗ

Πρόγραμμα ΘΕΜΑ_Γ_2009_ΕΠΑΝ_ΗΜΕΡ_Αναβαθμολογήσεις
Σταθερές
 Εξεταζόμενοι=5 ! Για την εκτέλεση στη ΓλωσσοΜάθεια, 780 για την άσκηση
Μεταβλητές
 Ακέραιες: i, j, Β[Εξεταζόμενοι,3], ΠΛ[6], θέση_Min, Min, S, Max
 Πραγματικές: Τ[Εξεταζόμενοι]

Αρχή
 Για i από 1 μέχρι Εξεταζόμενοι
     Γράψε 'Δώστε βαθμολογίες εξεταζομένου ', i
     Για j από 1 μέχρι 2
         Γράψε 'Βαθμολογητής ', j
         Διάβασε Β[i,j]
     Τέλος_Επανάληψης
 Τέλος_Επανάληψης

 ! Α
 Για i από 1 μέχρι Εξεταζόμενοι
     Αν Α_Τ(Β[i, 1] - Β[i, 2]) > 12 τότε
        Γράψε 'Δώστε βαθμό 3ου βαθμολογητή'
        Διάβασε Β[i, 3]
     Αλλιώς
        Β[i, 3] <-- -1
    Τέλος_αν
 Τέλος_επανάληψης

 ! B
 Για i από 1 μέχρι Εξεταζόμενοι
     Αν Β[i, 3] <> -1 τότε ! με αναβαθμολόγηση
        ! βρίσκω την μικρότερη βαθμολογία
        Min <-- Β[i, 1]
        θέση_Min <-- 1
        Για j από 2 μέχρι 3
            Αν Β[i, j] < Min τότε
               Min <-- Β[i, j]
               θέση_Min <-- j
            Τέλος_αν
        Τέλος_επανάληψης

       ! και την αποκλείω από το άθροισμα όλων
       S <-- 0
       Για j από 1 μέχρι 3
           Αν θέση_min <> j τότε
              S <-- S + Β[i, j]
           Τέλος_αν
       Τέλος_επανάληψης
       Τ[i] <-- S / 10
     Αλλιώς             ! χωρίς αναβαθμολόγηση
       Τ[i] <-- (Β[i, 1] + Β[i, 2]) / 10 
 Τέλος_αν
 Τέλος_επανάληψης

 ! Αρχικοποίηση ΠΛ
 Για j από 1 μέχρι 6
     ΠΛ[j] <-- 0
 Τέλος_επανάληψης

 Για j από 1 μέχρι 6
 ! Αν είχε γίνει εδώ η αρχικοποίηση του ΠΛ, ως ΠΛ[j] <-- 0 θα υπήρχε θέμα
    Για i από 1 μέχρι Εξεταζόμενοι
        Αν Τ[i] < 5 τότε
           ΠΛ[1] <-- ΠΛ[1] + 1
        Αλλιώς_αν Τ[i] < 10 τότε
           ΠΛ[2] <-- ΠΛ[2] + 1
        Αλλιώς_αν Τ[i] < 12 τότε
           ΠΛ[3] <-- ΠΛ[3] + 1
        Αλλιώς_αν Τ[i] < 15 τότε
           ΠΛ[4] <-- ΠΛ[4] + 1
        Αλλιώς_αν Τ[i] < 18 τότε
           ΠΛ[5] <-- ΠΛ[5] + 1
        Αλλιώς
           ΠΛ[6] <-- ΠΛ[6] + 1
        Τέλος_αν
    Τέλος_επανάληψης
 Τέλος_επανάληψης

 ! Γ
 Max <-- ΠΛ[1]
 Για j από 2 μέχρι 6
     Αν ΠΛ[j] > Max τότε
        Max <-- ΠΛ[j]
     Τέλος_αν
 Τέλος_επανάληψης

 Για j από 1 μέχρι 6
     Αν ΠΛ[j] = Max τότε
       Γράψε 'Μεγαλύτερο πλήθος γραπτών, στην κατηγορία ', j
     Τέλος_αν
 Τέλος_επανάληψης
Τέλος_Προγράμματος

 

Share This