Επιλογή Σελίδας

Μια εταιρεία έχει δύο υποκαταστήματα, ένα στην Αθήνα και ένα στη Θεσσαλονίκη. Σε κάθε υποκατάστημα εργάζονται 10 πωλητές.

Να αναπτύξετε αλγόριθμο σε ψευδογλώσσα, ο οποίος:
Δ1. Για καθέναν από τους 20 πωλητές της εταιρείας, να διαβάζει το όνομά του και τον κωδικό του και να τα καταχωρίζει σε κατάλληλο δισδιάστατο πίνακα, έτσι ώστε στις πρώτες 10 γραμμές του πίνακα να υπάρχουν τα στοιχεία των πωλητών του υποκαταστήματος της Αθήνας και στις επόμενες 10 τα στοιχεία των πωλητών της Θεσσαλονίκης. Να θεωρήσετε ότι όλα τα ονόματα και όλοι οι κωδικοί είναι διαφορετικοί μεταξύ τους. Μονάδες 2

Δ2. Για κάθε παραγγελία της εταιρείας στη διάρκεια του προηγούμενου έτους, να διαβάζει τον κωδικό του πωλητή. Αν ο κωδικός ανήκει σε πωλητή της εταιρείας, να διαβάζει το ποσό της αντίστοιχης παραγγελίας που πήρε ο πωλητής (δεν απαιτείται έλεγχος εγκυρότητας) ή, διαφορετικά, να εμφανίζει το μήνυμα «Άγνωστος κωδικός». Η επαναληπτική διαδικασία να τερματίζεται όταν δοθεί, ως κωδικός πωλητή, η τιμή ΤΕΛΟΣ. Μονάδες 8

Δ3. Να υπολογίζει τις συνολικές πωλήσεις κάθε πωλητή στη διάρκεια του προηγούμενου έτους και να τις εμφανίζει μαζί με το όνομά του. Να θεωρήσετε ότι κάθε πωλητής πήρε παραπάνω από μία παραγγελία στη διάρκεια του προηγούμενου έτους. Μονάδες 4

Δ4. Για κάθε υποκατάστημα να βρίσκει και να εμφανίζει τα ονόματα των τριών πωλητών με τις μεγαλύτερες συνολικές πωλήσεις στη διάρκεια του προηγούμενου έτους. Να θεωρήσετε ότι οι συνολικές πωλήσεις όλων των πωλητών είναι διαφορετικές μεταξύ τους. Μονάδες 6

ΦΥΛΛΑΔΙΟ ΘΕΜΑΤΩΝ

ΛΥΣΗ

ΑΡΧΕΙΟ ΔΕΔΟΜΕΝΩΝ

!ενδιαφέρουσα η ταξινόμηση διαφορετικών τμημάτων του ίδιου πίνακα
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ_2016_ΠΑΛΑΙΟ_ΕΠΑΝΑΛΗΠΤΙΚΕΣ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: i, j, position
 ΠΡΑΓΜΑΤΙΚΕΣ: ΣύνολοΠωλητή[20], ΠΑΡΑΓΓΕΛΙΑ, temp
 ΧΑΡΑΚΤΗΡΕΣ: ΟΝ_ΚΩΔ[20,2], ΚΩΔΙΚΟΣ, temp2
 ΛΟΓΙΚΕΣ: Έγκυρος_Κωδικός
ΑΡΧΗ
! Δ1
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΡΑΨΕ 'ΔΩΣΤΕ ΟΝΟΜΑ ΠΩΛΗΤΗ: '
     ΔΙΑΒΑΣΕ ΟΝ_ΚΩΔ[i,1]
     ΓΡΑΨΕ 'ΔΩΣΤΕ KΩΔΙΚΟ ΠΩΛΗΤΗ: '
     ΔΙΑΒΑΣΕ ΟΝ_ΚΩΔ[i,2]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ2
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20 ! Αρχικοποίηση
     ΣύνολοΠωλητή[i] <-- 0
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΡΑΨΕ 'ΝΕΑ ΠΑΡΑΓΓΕΛΙΑ'
 ΓΡΑΨΕ 'ΔΩΣΤΕ ΚΩΔΙΚΟ ΠΩΛΗΤΗ: '
 ΔΙΑΒΑΣΕ ΚΩΔΙΚΟΣ
 ΟΣΟ (ΚΩΔΙΚΟΣ <> 'TELOS') ΕΠΑΝΑΛΑΒΕ
 ! Αναζήτηση ύπαρξης του κωδικού στον ΚΩΔ[2,j]
      Έγκυρος_Κωδικός <-- ΨΕΥΔΗΣ
      i <-- 1
      ΟΣΟ (i<=20 ΚΑΙ Έγκυρος_Κωδικός = ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
           ΑΝ ΟΝ_ΚΩΔ[i,2] = ΚΩΔΙΚΟΣ ΤΟΤΕ
              Έγκυρος_Κωδικός <-- ΑΛΗΘΗΣ
              position <-- i
           ΑΛΛΙΩΣ
              i <-- i+1
           ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Έγκυρος_Κωδικός = ΑΛΗΘΗΣ ΤΟΤΕ
         ΓΡΑΨΕ 'ΔΩΣΤΕ ΠΟΣΟ ΠΑΡΑΓΓΕΛΙΑΣ: '
         ΔΙΑΒΑΣΕ ΠΑΡΑΓΓΕΛΙΑ
         ΣύνολοΠωλητή[position] <-- ΣύνολοΠωλητή[position] + ΠΑΡΑΓΓΕΛΙΑ
      ΑΛΛΙΩΣ
         ΓΡΑΨΕ 'ΑΓΝΩΣΤΟΣ ΚΩΔΙΚΟΣ'
      ΤΕΛΟΣ_ΑΝ
      ΓΡΑΨΕ 'ΔΩΣΤΕ ΚΩΔΙΚΟ ΠΩΛΗΤΗ: '
      ΔΙΑΒΑΣΕ ΚΩΔΙΚΟΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Δ3
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΡΑΨΕ 'ΠΩΛΗΤΗΣ: ',ΟΝ_ΚΩΔ[i,1], ' ΣΥΝΟΛΙΚΕΣ ΠΩΛΗΣΕΙΣ ΕΤΟΥΣ: ', ΣύνολοΠωλητή[i]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Δ4
!Ταξινόμηση Φυσαλίδας για τις πρώτες 10 θέσεις
 ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 10
     ΓΙΑ j ΑΠΟ 10 ΜΕΧΡΙ i με βήμα -1
         ΑΝ ΣύνολοΠωλητή[j-1] < ΣύνολοΠωλητή[j] ΤΟΤΕ
            temp <-- ΣύνολοΠωλητή[j-1]
            ΣύνολοΠωλητή[j-1] <-- ΣύνολοΠωλητή[j]
            ΣύνολοΠωλητή[j] <-- temp
            temp2 <-- ΟΝ_ΚΩΔ[j-1,1] ! Παράλληλη ταξινόμηση των ονομάτων
            ΟΝ_ΚΩΔ[j-1,1] <-- ΟΝ_ΚΩΔ[j,1]
            ΟΝ_ΚΩΔ[j,1] <-- temp2
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

!Ταξινόμηση Φυσαλίδας για τις επόμενες 10 θέσεις
 ΓΙΑ i ΑΠΟ 12 ΜΕΧΡΙ 20
     ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i με βήμα -1
         ΑΝ ΣύνολοΠωλητή[j-1] < ΣύνολοΠωλητή[j] ΤΟΤΕ
            temp <-- ΣύνολοΠωλητή[j-1]
            ΣύνολοΠωλητή[j-1] <-- ΣύνολοΠωλητή[j]
            ΣύνολοΠωλητή[j] <-- temp
            temp2 <-- ΟΝ_ΚΩΔ[j-1,1] ! Παράλληλη ταξινόμηση των ονομάτων
            ΟΝ_ΚΩΔ[j-1,1] <-- ΟΝ_ΚΩΔ[j,1]
            ΟΝ_ΚΩΔ[j,1] <-- temp2
         ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3
     ΓΡΑΨΕ 'ΟΙ 3 ΠΩΛΗΤΕΣ ΜΕ ΤΙΣ ΠΕΡΙΣΣΟΤΕΡΕΣ ΠΩΛΗΣΕΙΣ ΣΤΗΝ ΑΘΗΝΑ: ', ΟΝ_ΚΩΔ[i,1]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΓΙΑ i ΑΠΟ 11 ΜΕΧΡΙ 13
    ΓΡΑΨΕ 'ΟΙ 3 ΠΩΛΗΤΕΣ ΜΕ ΤΙΣ ΠΕΡΙΣΣΟΤΕΡΕΣ ΠΩΛΗΣΕΙΣ ΣΤΗΝ ΘΕΣΣΑΛΟΝΙΚΗ: ', ΟΝ_ΚΩΔ[i,1]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This