Επιλογή Σελίδας

Μια αλυσίδα ξενοδοχείων έχει 5 ξενοδοχεία. Σε ένα μονοδιάστατο πίνακα ΞΕΝΟΔΟΧΕΙΑ[5] καταχωρούνται τα ονόματα των ξενοδοχείων. Σε ένα άλλο δισδιάστατο πίνακα ΕΙΣΠΡΑΞΕΙΣ[5,12] καταχωρούνται οι εισπράξεις κάθε ξενοδοχείου για κάθε μήνα του έτους 2001, έτσι ώστε στην i γραμμή καταχωρούνται οι εισπράξεις του i ξενοδοχείου.

Να αναπτύξετε αλγόριθμο, ο οποίος:
α. διαβάζει τα στοιχεία των δύο πινάκων
Μονάδες 6

β. εκτυπώνει το όνομα κάθε ξενοδοχείου και τις ετήσιες εισπράξεις του για το έτος 2001
Μονάδες 7

γ. εκτυπώνει το όνομα του ξενοδοχείου με τις μεγαλύτερες εισπράξεις για το έτος 2001.
Μονάδες 7

ΛΥΣΗ:

Αλγόριθμος Ξενοδοχεία

(α) Για i από 1 μέχρι 5

Διάβασε ΞΕΝΟΔΟΧΕΙΑ[i]

Για j από 1 μέχρι 12

Διάβασε ΕΙΣΠΡΑΞΕΙΣ[i,j]

Τέλος_επανάληψης

Τέλος_επανάληψης

(β) Για i από 1 μέχρι 5

ΣΥΝΟΛΟ[i] <- 0

Για j από 1 μέχρι 12

ΣΥΝΟΛΟ[i] <- ΣΥΝΟΛΟ[i] + ΕΙΣΠΡΑΞΕΙΣ[i,j]

Τέλος_επανάληψης

Εμφάνισε ΞΕΝΟΔΟΧΕΙΑ[i], ΣΥΝΟΛΟ[i]

Τέλος_επανάληψης

(γ) max<-1

Για i από 2 μέχρι 5

Αν ΣΥΝΟΛΟ[i] > ΣΥΝΟΛΟ[max] τότε

max <- i

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε ΞΕΝΟΔΟΧΕΙΑ[max], ΣΥΝΟΛΟ[max]

Τέλος Ξενοδοχεία

Τα θέματα σε pdf, 2002, Επαναληπτικές, Ημερήσια

Share This