Επιλογή Σελίδας

Κατά τη διάρκεια Διεθνών Αγώνων Στίβου στον ακοντισμό έλαβαν μέρος δέκα (10) αθλητές. Κάθε αθλητής έκανε έξι (6) έγκυρες ρίψεις που καταχωρούνται ως επιδόσεις σε μέτρα. Να αναπτύξετε αλγόριθμο, ο οποίος:

α. εισάγει σε πίνακα δυο διαστάσεων τις επιδόσεις όλων των αθλητών
Μονάδες 3

β. υπολογίζει και καταχωρεί σε μονοδιάστατο πίνακα την καλύτερη από τις επιδόσεις κάθε αθλητή
Μονάδες 5

γ. ταξινομεί τις καλύτερες επιδόσεις των αθλητών που καταχωρήθηκαν στο μονοδιάστατο πίνακα
Μονάδες 8

δ. βρίσκει την καλύτερη επίδοση του αθλητή που πήρε το χάλκινο μετάλλιο (τρίτη θέση).
Μονάδες 4

ΛΥΣΗ:

Αλγόριθμος Ακόντιο

Για i από μέχρι 10

Max<- 0

Για j από 1 μέχρι 6

Διάβασε Βολές[i,j]

Αν Βολές[i,j] > max τότε 

Max <- Βολές[i,j]

Τέλος_αν 

Τέλος_επανάληψης 

Best[i]<- Max

Τέλος_επανάληψης 

Για από 2 μέχρι 10

Για j από 10 μέχρι i με_βήμα -1

Αν Best[j-1] < Best[j] τότε  Φθίνουσα ταξινόμηση

Αντιμετάθεσε Best[j-1] , Best[j]

Τέλος_αν 

Τέλος_επανάληψης 

Τέλος_επανάληψης 

Εμφάνισε “ Η καλύτερη επίδοση του 3ου αθλητή  είναι ”, Best[3]

Τέλος Ακόντιο

Τα θέματα σε pdf, 2001, Επαναληπτικές, Ημερήσια

Share This