Επιλογή Σελίδας

Έστω πίνακας table με Μ γραμμές και Ν στήλες που περιέχει αριθμητικές τιμές. Δίνεται ο παρακάτω αλγόριθμος που υπολογίζει το άθροισμα κατά γραμμή, κατά στήλη και συνολικά.

  1. Αλγόριθμος Αθρ_Πίνακα
  2. Δεδομένα // m, n, table //
  3. sum <- 0
  4. Για i από 1 μέχρι m
  5. row [i] <- 0
  6. Τέλος_επανάληψης
  7. Για j από 1 μέχρι n
  8. col [j] <- 0
  9. Τέλος_επανάληψης
  10. Για i από 1 μέχρι m
  11. Για j από 1 μέχρι n
  12. ______________ 
  13. ______________ 
  14. ______________ 
  15. Τέλος_επανάληψης
  16. Τέλος_επανάληψης
  17. Αποτελέσματα // row, col, sum  //
  18. Τέλος Αθρ_Πίνακα

Τα αθροίσματα των γραμμών καταχωρίζονται στον πίνακα row, των στηλών στον πίνακα col και το συνολικό άθροισμα στη μεταβλητή sum.
Να γράψετε στο τετράδιό σας τις εντολές που πρέπει να συμπληρωθούν στις γραμμές 12, 13 και 14, ώστε ο αλγόριθμος να επιτελεί τη λειτουργία που περιγράφτηκε.

Μονάδες 6

ΛΥΣΗ

  1. row[i] <- row[i] + table[i,j]
  2. col[j] <- col[j] + table[i,j]
  3. sum <- sum + table[i,j]
Share This