Επιλογή Σελίδας

Η έννοια του παραγοντικού είναι γνωστή από τα μαθηματικά. Πιο συγκεκριμένα, για ένα ακέραιο n, το n παραγοντικό, που συμβολίζεται με n!, ορίζεται από τη σχέση: n! = 1 x 2 x 3 x … x (n – 1) x n Ισοδύναμος είναι και ο εξής ορισμός n • (n – 1)! αν n > 0 1 αν n = 0 n! = Ο ορισμός αυτός διακρίνεται από το βασικό χαρακτηριστικό ότι το παραγοντικό εκφράζεται με βάση μία απλούστερη περίπτωση του εαυτού του. Δηλαδή εξ ορισμού το παραγοντικό είναι μία αναδρομική αλγεβρική συνάρτηση. Με τον επόμενο αλγόριθμο υπολογίζεται με πολύ απλό αναδρομικό τρόπο το n παραγοντικό.

Αλγόριθμος Παραγοντικό
 Δεδομένα // n //
 Αν n = 0 τότε
    product ← 1
 αλλιώς
    product ← n * Παραγοντικό(n—1)
 Τέλος_αν
 Αποτελέσματα // product //
 Τέλος Παραγοντικό

Ωστόσο, το n! μπορεί να υπολογισθεί και με επαναληπτική μέθοδο, όπως παρουσιάζεται στον επόμενο αλγόριθμο Παραγοντικό2.

Αλγόριθμος Παραγοντικό2
 Δεδομένα // n //
 product ← 1
 Για i από 2 μέχρι n
     product ← product * i
 Τέλος_επανάληψης
 Αποτελέσματα // product //
 Τέλος Παραγοντικό2

Επομένως, δοθέντων αυτών των δύο λύσεων στο πρόβλημα υπολογισμού του n παραγοντικού προκύπτει το εύλογο ερώτημα, ποια μέθοδος είναι καλύτερη. Αφού εξετάσουμε μερικά ακόμη παραδείγματα, στη συνέχεια θα δοθεί απάντηση στην ερώτηση αυτή.

Share This