Να υλοποιηθεί πρόγραμμα που διαβάζει τον αριθμό των αιθουσών ενός εξεταστικού κέντρου και κατόπιν το αριθμό των ατόμων που μπορεί να υποδεχθεί κάθε αίθουσα. Για κάθε αίθουσα θα διαβάζει την ηλικία των εξεταζόμενων και υπολογίζει και εμφανίζει την μεγαλύτερη, την μικρότερη ηλικία και τον μέσο όρο.
Προέκταση: Θα εμφανίζει τον μεγαλύτερο, μικρότερο εξεταζόμενο του εξεταστικού κέντρου και τον συνολικό μέσο όρο ηλικίας τους.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΥΨΟΣ_ΜΑΘΗΤΩΝ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: ΜΙΝ, ΜΑΧ, SUM, ΗΛΙΚΙΑ, ΑΙΘΟΥΣΕΣ, ΑΤΟΜΑ, i 
ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ
ΑΡΧΗ
!για ΌΛΕΣ τις αίθουσες
ΔΙΑΒΑΣΕ ΑΙΘΟΥΣΕΣ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ΑΙΘΟΥΣΕΣ

!για 1 αίθουσα τι κάνω
ΔΙΑΒΑΣΕ ΑΤΟΜΑ
! ΥΠΟΛΟΓΙΣΜΟΣ ΜΙΝ-ΜΑΧ
ΜΙΝ <--  100000
ΜΑΧ <-- -100000 

SUM <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ ΑΤΟΜΑ
! για κάθε άτομο
ΔΙΑΒΑΣΕ ΗΛΙΚΙΑ
! ΜΟ ηλικίας ατόμων της αίθουσας
SUM <-- SUM + ΗΛΙΚΙΑ

! ΥΠΟΛΟΓΙΣΜΟΣ ΜΙΝ
ΑΝ ΗΛΙΚΙΑ < ΜΙΝ ΤΟΤΕ 
       ΜΙΝ <-- ΗΛΙΚΙΑ
ΤΕΛΟΣ_ΑΝ

! ΥΠΟΛΟΓΙΣΜΟΣ ΜΑΧ
ΑΝ ΗΛΙΚΙΑ > ΜΑΧ ΤΟΤΕ 
       ΜΑΧ <-- ΗΛΙΚΙΑ
ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΟ <-- SUM/ΑΤΟΜΑ
ΓΡΑΨΕ ΜΟ
ΓΡΑΨΕ ΜΙΝ
ΓΡΑΨΕ ΜΑΧ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This