Επιλογή Σελίδας

Μια μαιευτική κλινική εφαρμόζει την παρακάτω πολιτική χρέωσης:

  • Το κόστος κάθε γέννας ξεκινάει με πάγιο 1500 ευρώ, το οποίο συμπεριλαμβάνει 2 διανυκτερεύσεις στην κλινική.
  • Το κόστος για κάθε επιπλέον διανυκτέρευση στην κλινική ακολουθεί κλιμακωτά τις χρεώσεις που φαίνονται στον παρακάτω πίνακα:
Διανυκτερεύσεις Τιμή (σε ευρώ) / Ημέρα
3-4 425
5-6 350
7-9 200
10 -….. 150
  • Το φιλανθρωπικό τμήμα της κλινικής ορίζει πως θα δίνεται επιστροφή χρημάτων σε κάθε μέλλουσα μητέρα, κλιμακωτά ανάλογα με τον αριθμό παιδιών της (μαζί με το καινούριο της μέλος !), σύμφωνα με τον παρακάτω πίνακα:
Αριθμός παιδιών Έκπτωση (σε ευρώ) / Παιδί
1-2 150
3-6 250
7-…… 400

 Να γίνει πρόγραμμα σε γλώσσα προγραμματισμού «ΓΛΩΣΣΑ» το οποίο:

  1. Να περιέχει τμήμα δήλωσης μεταβλητών και σταθερών.

(ΜΟΝΑΔΕΣ 2)

  1. Να διαβάζει τον αριθμό των διανυκτερεύσεων που έμεινε μια μητέρα στην κλινική κάνοντας ταυτόχρονα έλεγχο ώστε να είναι αριθμός τουλάχιστον ίσος με 2 και να υπολογίζει το κόστος διαμονής με βάση τον παραπάνω (πρώτο κατά σειρά) πίνακα.

(ΜΟΝΑΔΕΣ 8)

  1. Να διαβάζει τον αριθμό των παιδιών που έχει πλέον η οικογένειά της (συμπεριλαμβανομένου και του καινούριου της μέλους) και να υπολογίζει την έκπτωση που θα της κάνει η κλινική, με βάση τον παραπάνω (δεύτερο κατά σειρά) πίνακα.

(ΜΟΝΑΔΕΣ 8)

  1. Να υπολογίζει το τελικό ποσό που πρέπει να καταβάλλει στην κλινική (μαζί με το πάγιο) και να το εμφανίζει στην οθόνη μετά από το μήνυμα «ΝΑ ΣΑΣ ΖΗΣΕΙ».

(ΜΟΝΑΔΕΣ 2)

ΜΟΝΑΔΕΣ 20

ΛΥΣΗ 

ΠΡΟΓΡΑΜΜΑ ΚΛΙΝΙΚΗ
!Ερώτημα 1
ΣΤΑΘΕΡΕΣ
ΠΑΓΙΟ = 1500
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ, ΠΑΙΔΙΑ
ΠΡΑΓΜΑΤΙΚΕΣ: ΚΟΣΤΟΣ, ΕΚΠΤΩΣΗ, ΤΕΛΙΚΟ_ΠΟΣΟ
ΛΟΓΙΚΕΣ: ΟΛΟΚΛΗΡΩΘΗΚΕ 
ΑΡΧΗ

!Ερώτημα 2
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ ΗΜΕΡΩΝ ΔΙΑΝΥΚΤΕΡΕΥΣΗΣ (>=2)'
    ΔΙΑΒΑΣΕ ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ
ΜΕΧΡΙΣ_ΟΤΟΥ ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ >= 2
ΑΝ ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ = 2 ΤΟΤΕ
   ΚΟΣΤΟΣ <-- ΠΑΓΙΟ
ΑΛΛΙΩΣ_ΑΝ ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ <5 ΤΟΤΕ
   ΚΟΣΤΟΣ <-- ΠΑΓΙΟ + (ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ - 2) * 425
ΑΛΛΙΩΣ_ΑΝ ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ <7 ΤΟΤΕ
   ΚΟΣΤΟΣ <-- ΠΑΓΙΟ + 2 * 425 + (ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ - 4) * 350
ΑΛΛΙΩΣ_ΑΝ ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ <9 ΤΟΤΕ
   ΚΟΣΤΟΣ <-- ΠΑΓΙΟ + 2 * 425 + 2 * 350 + (ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ - 6) * 200
ΑΛΛΙΩΣ
   ΚΟΣΤΟΣ <-- ΠΑΓΙΟ + 2 * 425 + 2 * 350 + 2 * 200 + (ΔΙΑΝΥΚΤΕΡΕΥΣΕΙΣ - 8) * 150
ΤΕΛΟΣ_ΑΝ

!Ερώτημα 3
ΓΡΑΨΕ 'ΔΩΣΕ ΑΡΙΘΜΟ ΠΑΙΔΙΩΝ'
ΔΙΑΒΑΣΕ ΠΑΙΔΙΑ
ΠΑΙΔΙΑ <-- ΠΑΙΔΙΑ + 1 !Περιλαμβάνεται το νέο μέλος
ΑΝ ΠΑΙΔΙΑ <= 2 ΤΟΤΕ
   ΕΚΠΤΩΣΗ <-- ΠΑΙΔΙΑ * 150
ΑΛΛΙΩΣ_ΑΝ ΠΑΙΔΙΑ <=6 ΤΟΤΕ
   ΕΚΠΤΩΣΗ <-- 2 * 150 + (ΠΑΙΔΙΑ-2) * 250
ΑΛΛΙΩΣ
   ΕΚΠΤΩΣΗ <-- 2* 150 + 4 * 250 + (ΠΑΙΔΙΑ - 6) * 400
ΤΕΛΟΣ_ΑΝ

!Ερώτημα 4
ΤΕΛΙΚΟ_ΠΟΣΟ <-- ΚΟΣΤΟΣ - ΕΚΠΤΩΣΗ
ΓΡΑΨΕ 'ΝΑ ΣΑΣ ΖΗΣΕΙ'
ΓΡΑΨΕ 'ΣΤΗ ΚΛΙΝΙΚΗ ΟΦΕΙΛΕΤΕ', ΤΕΛΙΚΟ_ΠΟΣΟ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This