Επιλογή Σελίδας

Μια αυτόματη μηχανή παγωτού πουλάει μπάλες παγωτού 4 γεύσεων. Να γίνει πρόγραμμα σε ΓΛΩΣΣΑ που:

  1. θα περιέχει τμήμα δήλωσης μεταβλητών          (ΜΟΝΑΔΕΣ 2)
  2. θα ‘φορτίζει’ το μηχάνημα με αρχικό απόθεμα 50 μπάλες παγωτού σε κάθε μια από 4 γεύσεις   (ΜΟΝΑΔΕΣ 2)

Για κάθε πελάτη που θέλει να αγοράσει παγωτό:

  1. θα εμφανίζεται το παρακάτω μενού επιλογών:
    1. ΒΑΝΙΛΙΑ
    2. ΣΟΚΟΛΑΤΑ
    3. ΦΥΣΤΙΚΙ
    4. ΜΠΑΝΑΝΑ
    5. ΕΞΟΔΟΣ

(ΜΟΝΑΔΕΣ 2)

  1. Θα διαβάζει επαναληπτικά την επιλογή του πελάτη η οποία θα είναι ένας ακέραιος αριθμός από το 1 μέχρι το 5. Να πραγματοποιηθεί έλεγχος εγκυρότητας στην επιλογή του πελάτη ώστε να μπορεί να παίρνει τις επιθυμητές τιμές. (ΜΟΝΑΔΕΣ 2)
  1. Στην περίπτωση που πατηθεί ο αριθμός 5 τότε το πρόγραμμα να εμφανίζει το ποσό που πρέπει να πληρωθεί, λαμβάνοντας υπόψη πως κάθε μπάλα παγωτού κοστίζει 0.5 ευρώ.  (ΜΟΝΑΔΕΣ 2)
  2. Σε περίπτωση που πατηθεί ένας αριθμός από 1 μέχρι 4:
    1. το πρόγραμμα θα πρέπει να ελέγχει αν υπάρχει απόθεμα της διαθέσιμης ποσότητας της γεύσης παγωτού που ζητάει ο πελάτης και αν υπάρχει τότε να ενημερώνεται αυτόματα η διαθέσιμη ποσότητα.
    2. Αν δεν υπάρχει διαθέσιμη η ποσότητα να εμφανίζεται το μήνυμα ‘ΔΥΣΤΥΧΩΣ Η ΓΕΥΣΗ ΠΟΥ ΕΠΙΛΈΞΑΤΕ ΤΕΛΕΙΩΣΕ’ (ΜΟΝΑΔΕΣ 2)
  1. Θα εμφανίζει πόσο κόστιζε το ακριβότερο παγωτό που δόθηκε από το μηχάνημα. (ΜΟΝΑΔΕΣ 2)
  2. Να εμφανίζει πόσοι πελάτες αγόρασαν παγωτό. (ΜΟΝΑΔΕΣ 2)
  3. Να εμφανίζει το συνολικό κέρδος της μηχανής. (ΜΟΝΑΔΕΣ 2)
  4. Η επαναληπτική διαδικασία να σταματάει όταν τελειώσουν τα αποθέματα των 2 πρώτων γεύσεων που φαίνονται στο μενού και να εμφανίζονται τα αποτελέσματα, μετά από το μήνυμα ‘ΔΥΣΤΥΧΩΣ ΔΕΝ ΜΠΟΡΟΥΜΕ ΝΑ ΣΑΣ ΕΞΥΠΗΡΕΤΗΣΟΥΜΕ’  (ΜΟΝΑΔΕΣ 2)

ΠΑΡΑΤΗΡΗΣΗ: Υποθέτουμε ότι κάθε πελάτης θα πάρει τουλάχιστον μια μπάλα παγωτό

ΜΟΝΑΔΕΣ 20

ΛΥΣΗ 

ΠΡΟΓΡΑΜΜΑ ΠΑΓΩΤΟΜΗΧΑΝΗ

!Ερώτημα 1
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:ΒΑ, ΣΟ, ΦΥ, ΜΠ, ΕΠΙΛΟΓΗ, ΜΠΑΛΕΣ, ΠΕΛΑΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: ΚΟΣΤΟΣ, ΚΕΡΔΟΣ, ΜΑΧΚΟΣΤΟΣ
ΛΟΓΙΚΕΣ: ΟΛΟΚΛΗΡΩΘΗΚΕ
ΑΡΧΗ

!Ερώτημα 2
ΒΑ<-- 50 ! Μπάλες Βανίλια
ΣΟ<-- 50 ! Μπάλες Σοκολάτα
ΦΥ<-- 50 ! Μπάλες Φιστίκι
ΜΠ<-- 50 ! Μπάλες Μπανάνα

!Ερώτημα 10 - Εξυπηρέτηση πολλών πελατών
ΠΕΛΑΤΕΣ <-- 0 
ΜΑΧΚΟΣΤΟΣ <-- 0
ΚΕΡΔΟΣ <-- 0 
ΟΣΟ ΒΑ > 0 ΚΑΙ ΣΟ >0 ΕΠΑΝΑΛΑΒΕ

    ! Ερώτημα 6. Δημιουργία ενός Παγωτού
    ΜΠΑΛΕΣ<-- 0
    ΚΟΣΤΟΣ<-- 0
    ΟΛΟΚΛΗΡΩΘΗΚΕ <-- ΨΕΥΔΗΣ ! Η επιλογή γεύσεων είναι σε εξέλιξη
    ΟΣΟ ΟΛΟΚΛΗΡΩΘΗΚΕ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
        !Ερώτημα 3 - Μενού επιλογών
        ΓΡΑΨΕ '1.ΒΑΝΙΛΙΑ'
        ΓΡΑΨΕ '2.ΣΟΚΟΛΑΤΑ'
        ΓΡΑΨΕ '3.ΦΙΣΤΙΚΙ'
        ΓΡΑΨΕ '4.ΜΠΑΝΑΝΑ'
        ΓΡΑΨΕ '5.ΕΞΟΔΟΣ'

        !Ερώτημα 4. Έλεγχος εισόδου
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΡΑΨΕ 'ΔΩΣΕ ΕΠΙΛΟΓΗ (1-5)'
            ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ 
        ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ >=1 ΚΑΙ ΕΠΙΛΟΓΗ <=5

        !Ερώτημα 6. Επιλογή Γεύσης
        ΑΝ ΕΠΙΛΟΓΗ <> 5 ΤΟΤΕ 
           ΑΝ ΕΠΙΛΟΓΗ = 1 ΤΟΤΕ
              ΑΝ ΒΑ > 0 ΤΟΤΕ 
                 ΒΑ <-- ΒΑ - 1
              ΑΛΛΙΩΣ 
                 ΓΡΑΨΕ 'ΔΥΣΤΥΧΩΣ Η ΓΕΥΣΗ ΠΟΥ ΕΠΙΛΈΞΑΤΕ ΤΕΛΕΙΩΣΕ'   
              ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 2 ΤΟΤΕ
                 ΑΝ ΣΟ > 0 ΤΟΤΕ 
                   ΣΟ <-- ΣΟ - 1
                 ΑΛΛΙΩΣ 
                   ΓΡΑΨΕ 'ΔΥΣΤΥΧΩΣ Η ΓΕΥΣΗ ΠΟΥ ΕΠΙΛΈΞΑΤΕ ΤΕΛΕΙΩΣΕ'   
                 ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 3 ΤΟΤΕ
                 ΑΝ ΦΥ > 0 ΤΟΤΕ 
                    ΦΥ <-- ΦΥ - 1
                 ΑΛΛΙΩΣ 
                    ΓΡΑΨΕ 'ΔΥΣΤΥΧΩΣ Η ΓΕΥΣΗ ΠΟΥ ΕΠΙΛΈΞΑΤΕ ΤΕΛΕΙΩΣΕ'   
                 ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 4 ΤΟΤΕ
                 ΑΝ ΦΥ > 0 ΤΟΤΕ 
                    ΦΥ <-- ΦΥ - 1
                 ΑΛΛΙΩΣ 
                    ΓΡΑΨΕ 'ΔΥΣΤΥΧΩΣ Η ΓΕΥΣΗ ΠΟΥ ΕΠΙΛΈΞΑΤΕ ΤΕΛΕΙΩΣΕ'   
                 ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΑΝ
           ΜΠΑΛΕΣ <-- ΜΠΑΛΕΣ + 1        
        ΑΛΛΙΩΣ     ! Ερώτημα 5, (ΕΠΙΛΟΓΗ = 5)
           ΟΛΟΚΛΗΡΩΘΗΚΕ <-- ΑΛΗΘΗΣ
           ΚΟΣΤΟΣ <-- ΚΟΣΤΟΣ + ΜΠΑΛΕΣ * 0.5
           ΓΡΑΨΕ 'ΤΟ ΠΑΓΩΤΟ ΚΟΣΤΙΖΕΙ ', ΚΟΣΤΟΣ
        ΤΕΛΟΣ_ΑΝ 
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    
    !Ερώτημα 7
    ΑΝ ΜΑΧΚΟΣΤΟΣ < ΚΟΣΤΟΣ ΤΟΤΕ
       ΜΑΧΚΟΣΤΟΣ <-- ΚΟΣΤΟΣ
    ΤΕΛΟΣ_ΑΝ
    
    !Ερώτημα 8
    ΠΕΛΑΤΕΣ <-- ΠΕΛΑΤΕΣ + 1

    !Ερώτημα 9
    ΚΕΡΔΟΣ <-- ΚΕΡΔΟΣ + ΚΟΣΤΟΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ 'ΔΥΣΤΥΧΩΣ ΔΕΝ ΜΠΟΡΟΥΜΕ ΝΑ ΣΑΣ ΕΞΥΠΗΡΕΤΗΣΟΥΜΕ' 
ΓΡΑΨΕ 'ΣΥΝΟΛΙΚΟ ΚΕΡΔΟΣ ΠΑΓΩΤΟΜΗΧΑΝΗΣ: ', ΚΕΡΔΟΣ
ΓΡΑΨΕ 'ΤΙΜΗ ΑΚΡΙΒΟΤΕΡΟΥ ΠΑΓΩΤΟΥ ΠΟΥ ΠΩΛΗΘΗΚΕ: ', ΜΑΧΚΟΣΤΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Share This