Επιλογή Σελίδας

Να γράψεις ένα πρόγραμμα το οποίο διαβάζει την τιμή βιβλίων σε ΕΥΡΩ και μετατρέπει τις τιμές τους σε Δραχμές, Γερμανικά Μάρκα, Γαλλικά Φράγκα και Ιταλικές Λιρέτες. Να χρησιμοποιήσεις για τις μετατροπές τις τρέχουσες ισοτιμίες των νομισμάτων.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ Μετατροπή_Νομισμάτων
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Λίρες, Κορώνες, Φράγκα, Δολάρια, Ευρώ
ΑΚΕΡΑΙΕΣ: ΕΠΙΛΟΓΗ
ΑΡΧΗ
ΓΡΑΨΕ 'Δώσε τιμή σε Ευρώ: '
ΔΙΑΒΑΣΕ Ευρώ
ΚΑΛΕΣΕ Μενού(ΕΠΙΛΟΓΗ)
ΑΝ ΕΠΙΛΟΓΗ = 1 ΤΟΤΕ
   Λίρες <-- Ευρώ * 0.85
   ΓΡΑΨΕ 'Τιμή σε Αγγλικές Λίρες ', Λίρες
ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=2 ΤΟΤΕ
   Κορώνες <-- Ευρώ * 9.6
   ΓΡΑΨΕ 'Τιμή σε Σουηδικές Κορώνες ', Κορώνες
ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ = 3 ΤΟΤΕ
   Φράγκα <-- Ευρώ * 1.075
   ΓΡΑΨΕ 'Τιμή σε Ελβετικά Φράγκα ', Φράγκα
ΑΛΛΙΩΣ_ΑΝ ΕΠΙΛΟΓΗ=4 ΤΟΤΕ
   Δολάρια <-- Ευρώ * 1.045
   ΓΡΑΨΕ 'Τιμή σε Δολάρια ', Δολάρια
ΑΛΛΙΩΣ
   ΓΡΑΨΕ 'Δεν υποστηρίζεται ακόμη αυτή η επιλογή'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
! επαναχρησιμοποίηση από την άσκηση ΔΣ4.Κεφάλαιο 10
ΔΙΑΔΙΚΑΣΙΑ Μενού(επιλογή)
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ:επιλογή
ΑΡΧΗ
  ΓΡΑΨΕ '1. Αγγλική Λίρα'
  ΓΡΑΨΕ '2. Σουηδική Κορώνα'
  ΓΡΑΨΕ '3. Ελβετικό Φράγκο'
  ΓΡΑΨΕ '4. Δολλάριο'
  ΓΡΑΨΕ '5. Έξοδος'
  ΓΡΑΨΕ 'Επίλεξε υπολογισμό (1-5)'
  ΔΙΑΒΑΣΕ επιλογή
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Share This