Επιλογή Σελίδας

Να ξαναγράψεις το πρόγραμμα της ΔΕ1 χρησιμοποιώντας αναδρομικές συναρτήσεις. Σύγκρινε τα δύο προγράμματα.

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΔΕ4_ΜΚΔ_ΕΚΠ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Α, Β
ΑΡΧΗ
ΓΡΑΨΕ 'ΔΩΣΕ 2 ΘΕΤΙΚΟΥΣ ΑΡΙΘΜΟΥΣ'
ΔΙΑΒΑΣΕ Α, Β
ΓΡΑΨΕ 'ΜΚΔ = ', ΜΚΔ(Α,Β)
ΓΡΑΨΕ 'ΕΚΠ = ', ΕΚΠ(Α,Β)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Αλγόριθμος του Ευκλείδη (Αναδρομικός - ΕΚΤΟΣ ΥΛΗΣ)
ΣΥΝΑΡΤΗΣΗ ΜΚΔ(x,y): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x,y
ΑΡΧΗ
ΑΝ y = 0 ΤΟΤΕ
   ΜΚΔ <-- x
ΑΛΛΙΩΣ_ΑΝ (x > y ΚΑΙ y>0) ΤΟΤΕ
    ΜΚΔ <-- ΜΚΔ(y,x MOD y)
ΑΛΛΙΩΣ
    ΜΚΔ <-- ΜΚΔ(y,x)
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

! ΕΚΠ σε σχέση με το ΜΚΔ
! x * y = ΕΚΠ (x, y) * ΜΚΔ (x, y)
ΣΥΝΑΡΤΗΣΗ ΕΚΠ(x,y): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: x,y
ΑΡΧΗ
ΕΚΠ <-- x*y / ΜΚΔ(x,y)
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Share This