Μία εταιρεία μεταφοράς δεμάτων διαθέτει δύο αποθήκες, Α και Β, στο αεροδρόμιο. Κατά την παραλαβή δεμάτων, κάθε δέμα τοποθετείται στην αποθήκη που έχει εκείνη τη στιγμή τον περισσότερο ελεύθερο χώρο. Αν ο ελεύθερος χώρος της αποθήκης Α είναι ίσος με τον ελεύθερο χώρο της αποθήκης Β, το δέμα τοποθετείται στην αποθήκη Α. Όταν όμως το δέμα δεν χωρά σε καμία από τις δύο αποθήκες, προωθείται στις κεντρικές εγκαταστάσεις της εταιρείας, που βρίσκονται εκτός αεροδρομίου.
Γ1. Να κατασκευάσετε πρόγραμμα που:
α. Να περιλαμβάνει κατάλληλο τμήμα δηλώσεων. (μονάδες 0,5)
β. Να διαβάζει τα μεγέθη ελεύθερου χώρου των αποθηκών Α και Β. (μονάδες 0,5) ! ο χώρος είναι ακέραια κυβικά μέτρα
γ. Να διαβάζει το μέγεθος κάθε εισερχόμενου δέματος (κυβικά μέτρα με υποδιαστολή) και να εμφανίζει το όνομα της αποθήκης (Α ή Β) στην οποία θα τοποθετηθεί αυτό ή να εμφανίζει το μήνυμα «Προώθηση», όταν το δέμα δεν χωρά σε καμία από τις αποθήκες Α ή Β. Η διαδικασία παραλαβής τερματίζεται, όταν εισαχθεί ως μέγεθος δέματος η τιμή 0. (μονάδες 4)

Βλέπε Θέμα Γ, 2015
https://aepp.gr/thema-g-2015-imerisia/

Λύση

ΠΡΟΓΡΑΜΜΑ ΑΠΟΘΗΚΗ
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Χ1, Χ2
ΑΡΧΗ
ΔΙΑΒΑΣΕ Χ1,Χ2
ΔΙΑΒΑΣΕ Δ
ΟΣΟ Δ<>0 ΕΠΑΝΑΛΑΒΕ   
ΑΝ Χ1>=Χ2 ΤΟΤΕ                     !ΠΟΙΑ ΑΠΟΘΗΚΗ ΕΙΝΑΙ ΜΕΓΑΛΥΤΕΡΗ;
      ΑΝ Χ1-Δ>=0 ΤΟΤΕ              !ΧΩΡΑ ΣΤΗΝ ΑΠΟΘΗΚΗ Α;
             Χ1<-- Χ1-Δ            !ΒΑΛΤΟ ΣΤΗΝ Α, ΜΕΙΩΣΕ ΤΟΝ ΧΩΡΟ ΚΑΤΑ Δ
             ΓΡΑΨΕ ‘Α’                   
      ΑΛΛΙΩΣ
             ΓΡΑΨΕ ‘ΠΡΟΩΘΗΣΗ’      !ΣΤΕΙΛΤΟ ΣΤΟ ΑΕΡΟΔΡΟΜΙΟ
      ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ                             ! ΙΔΙΑ ΔΙΑΔΙΚΑΣΙΑ ΑΚΡΙΒΩΣ ΜΕ ΤΗΝ ΑΝ ΑΛΛΑ ΓΙΑ Χ2
     ΑΝ Χ2-Δ>=0 ΤΟΤΕ               !ΧΩΡΑ ΣΤΗΝ ΑΠΟΘΗΚΗ Β;
     Χ1<-- Χ1-Δ
     ΓΡΑΨΕ ‘Β’
     ΑΛΛΙΩΣ
            ΓΡΑΨΕ ‘ΠΡΟΩΘΗΣΗ’ 
     ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΔΙΑΒΑΣΕ Δ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This