Επιλογή Σελίδας
Οι τελεστικοί ενισχυτές είναι ηλεκτρονικές διατάξεις οι οποίες επιτρέπουν την τέλεση αριθμητικών πράξεων μεταξύ των αναλογικών σημάτων των εισόδων τους. Ειδική κατηγορία τελεστικών ενισχυτών αποτελούν οι αθροιστές στους οποίους συνδέουμε δύο καλώδια εισόδου και εκεί κατευθύνουμε δύο σήματα σε μορφή ηλεκτρικού ρεύματος που μετριέται ως ένας θετικός ή αρνητικός αριθμός. Σε ένα άλλο καλώδιο παρέχουν ως έξοδο το αναλογικό άθροισμα των σημάτων εισόδου τους, πάλι σε μορφή ηλεκτρικού ρεύματος.
Η απόδοση των ενισχυτών αυτών είναι ιδιαίτερα υψηλή για σήματα εισόδου που έχουν άθροισμα κοντά στο 0.
Για παράδειγμα, καλή απόδοση υπάρχει για δύο σήματα εισόδου που έχουν μεταξύ τους περίπου αντίθετες τιμές, όπως 13 και -12.
Οι τελεστικοί ενισχυτές βρίσκουν μεγάλη εφαρμογή σήμερα. Για παράδειγμα χρησιμοποιούνται για τη μίξη ηχητικών σημάτων.
Πρόβλημα
Να αναπτύξετε ένα πρόγραμμα σε Γλώσσα το οποίο θα δέχεται ως είσοδο Ν ακέραιους αριθμούς (θετικούς και αρνητικούς) σε αύξουσα σειρά. Το πρόγραμμα θα βρίσκει τους δύο αριθμούς που το άθροισμά τους είναι πιο κοντά στο 0 ώστε να “οδηγήσει” τα αντίστοιχα κανάλια στον κατάλληλο τελεστικό ενισχυτή. (Αν υπάρχουν περισσότερα από ένα ζεύγη αριθμών με το ίδιο βέλτιστο άθροισμα, επιλέξτε ένα οποιοδήποτε.)
ΛΥΣΗ

 

ΠΡΟΓΡΑΜΜΑ ΑΣΚ6_ΠΑΡ_Β_ΙΕΠ_amplifiers
ΣΤΑΘΕΡΕΣ
  Ν=10
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, j, Α[Ν], min, distance, channel1, channel2

ΑΡΧΗ
  ! Είσοδος σε αύξουσα σειρά 
  ΔΙΑΒΑΣΕ Α[1]
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ Ν
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
       ΔΙΑΒΑΣΕ Α[i]
    ΜΕΧΡΙΣ_ΟΤΟΥ Α[i] > Α[i-1]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  min <-- 1000
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν  ! Όπως διαβάζουμε έναν άνω τριγωνικό πίνακα
    ΓΙΑ j ΑΠΟ Ν ΜΕΧΡΙ i+1 ΜΕ ΒΗΜΑ -1
      ΓΡΑΨΕ Α[i] , Α[j]
      distance <-- Α_Τ( Α[i] + Α[j] )
      ΑΝ distance < min ΤΟΤΕ
        min <-- distance
        channel1 <-- Α[i]
        channel2 <-- Α[j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΓΡΑΨΕ channel1, channel2

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Share This