Επιλογή Σελίδας
Το Εργαστήριο Υδρολογίας του Εθνικού Μετσόβιου Πολυτεχνείου (ΕΜΠ), έχει αναπτύξει ένα Γεωγραφικό Σύστημα Πληροφοριών (Geographic Information System: GIS) για την εποπτεία των υδρολογικών δεδομένων του Ελλαδικού χώρου (http://titan.chi.civil.ntua.gr/website/greece/viewer.htm). Οι υπεύθυνοι υδροπληροφορικής αναπτύσσουν πολλές εφαρμογές για την επεξεργασία σεπραγματικό χρόνο πλειάδας υδρολογικών δεδομένων.
Για τον υπολογισμό των υδάτινων αποθεμάτων, χρησιμοποιούνται πολλές παράμετροι με κυριότερες: τα εκατοστόμετρα βροχόπτωσης Ν και τις ημέρες ηλιοφάνειας (εξατμισοδιαπνοής) Μ,
με τους αντίστοιχους συντελεστές a και b για τη λεκάνη απορροής την οποία μελετάμε. Ιδιαίτερο ενδιαφέρον παρουσιάζει το γεγονός ότι με χρήση κατάλληλων συντελεστών, κάθε εκατοστόμετρο βροχής λειτουργεί πολλαπλασιαστικά στα αποθέματα που έχουν συσσωρευτεί προηγούμενα και κάθε μέρα ηλιοφάνειας προσθετικά στην εξάτμιση. Παραδείγματος χάριν, για 15 εκατοστόμετρα βροχόπτωσης και 100 μέρες ηλιοφάνειας ο συνολικός όγκος νερού που συγκεντρώνεται (σε κυβικά μέτρα) είναι:
V = Vr + a * (1*2*3* … *15)/1000000 – b * (1+2+3+ … +100)
(Vr: Υφιστάμενα αποθέματα, a: συν. συγκέντρωσης, b: συν. εξάτμισης).
Πρόβλημα:
Να αναπτύξετε ένα πρόγραμμα το οποίο θα διαβάζει τις παραπάνω τιμές και θα εμφανίζει τα υδάτινα αποθέματα μιας λεκάνης απορροής. Ο εμφανιζόμενος αριθμός θα είναι ο πλησιέστερος ακέραιος στα κυβικά μέτρα υδάτινων αποθεμάτων.
ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΑΣΚ3_ΒΑΣΙΚΕΣ_ΕΝΝΟΙΕΣ_ΙΕΠ_ΠΑΡ_Β
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: a, b, N, M, p, s, i, Vr, V
  ΠΡΑΓΜΑΤΙΚΕΣ: Vd   
ΑΡΧΗ
! Για τους αριθμούς αυτούς ισχύει:
! (10 < N <= 20), (1 <= Μ <= 365), (1000 <= Vr <= 1000000), (1 <= a, b <= 1000).

  ΓΡΑΨΕ 'Δώστε εκατοστόμετρα βροχόπτωσης (10 < N <= 20):'
  ΔΙΑΒΑΣΕ N
  ΓΡΑΨΕ 'Δώστε ημέρες ηλιοφάνειας (1 <= Μ <= 365):'
  ΔΙΑΒΑΣΕ M
  ΓΡΑΨΕ 'Δώστε υφιστάμενα αποθέματα (1000 <= Vr <= 1000000):'
  ΔΙΑΒΑΣΕ Vr
  ΓΡΑΨΕ 'Δώστε συντελεστή συγκέντρωσης (1 <= a <= 1000):'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ 'Δώστε συντελεστή εξάτμισης (1 <= b <= 1000):'
  ΔΙΑΒΑΣΕ b

  ! υπολογισμός όρου 1*2*....*Ν  (Ν παραγοντικό)
  ΑΝ M=0 ΤΟΤΕ   ! Αν και Μ = 0 δεν είναι αποδεκτή τιμή στο τύπο
    p <-- 1
  ΑΛΛΙΩΣ
    p <-- 1
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ N
      p <-- p*i
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ

  ! υπολογισμός όρου 1+2+3+...+Μ
  s <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ M
    s <-- s+i
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ! τύπος υπολογισμού του V
  Vd <-- Vr + a * p / 1000000 - b * s

  ! στρογγυλοποίηση Vreal στον πλησιέστερο ακέραιο
  ΑΝ Vd - Α_Μ(Vd) > 0.5 ΤΟΤΕ
    V <-- Α_Μ(Vd) + 1
  ΑΛΛΙΩΣ
    V <-- Α_Μ(Vd)
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ 'υδάτινα αποθέματα (V):', V
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
                      






Share This