Επιλογή Σελίδας

Σε μια διαδρομή τρένου υπάρχουν 20 σταθμοί (σε αυτούς περιλαμβάνονται η αφετηρία και ο τερματικός σταθμός). Το τρένο σταματά σε όλους τους σταθμούς. Σε κάθε σταθμό επιβιβάζονται και αποβιβάζονται επιβάτες. Οι πρώτοι επιβάτες επιβιβάζονται στην αφετηρία και στον τερματικό σταθμό αποβιβάζονται όλοι οι επιβάτες.

Να κατασκευάσετε αλγόριθμο, ο οποίος να διαχειρίζεται την κίνηση των επιβατών. Συγκεκριμένα:

Α.   Να ζητάει από το χρήστη τον αριθμό των ατόμων που επιβιβάστηκαν σε κάθε σταθμό, εκτός από τον τερματικό, και να τον εισάγει σε πίνακα ΕΠΙΒ[19].

Μονάδες 2

Β. Να εισάγει σε πίνακα ΑΠΟΒ[19] τον αριθμό των ατόμων που αποβιβάστηκαν σε κάθε σταθμό, εκτός από τον τερματικό, ως εξής:

Για την αφετηρία να εισάγει την τιμή μηδέν (0) και για τους υπόλοιπους σταθμούς να ζητάει από τον χρήστη τον αριθμό των ατόμων που αποβιβάστηκαν.

Μονάδες 4

Γ. Να δημιουργεί πίνακα ΑΕ[19], στον οποίο να καταχωρίζει τον αριθμό των επιβατών που βρίσκονται στο τρένο, μετά από κάθε αναχώρησή του.

Μονάδες 7

Δ. Να βρίσκει και να εμφανίζει τον σταθμό από τον οποίο το τρένο αναχωρεί με τον μεγαλύτερο αριθμό επιβατών. (Να θεωρήσετε ότι από κάθε σταθμό το τρένο αναχωρεί με διαφορετικό αριθμό επιβατών).

Μονάδες 7

Τα θέματα σε pdf, 2009, Μαΐου-Ιουνίου, Ημερήσια

ΛΥΣΗ


ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2009_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: i, Πλήθος, ΑΕ[19], ΑΠΟΒ[19], ΕΠΙΒ[19], μέγιστο, μεγ_σταθμός
ΑΡΧΗ
  ! Α.
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 19    ! Οι σταθμοί χωρίς τον τερματικό
    ΓΡΑΨΕ 'Δώστε αριθμό ατόμων που επιβιβάστηκαν στον ', i, 'σταθμό '
    Διάβασε ΕΠΙΒ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΠΟΒ[1] <-- 0           ! 0 αποβιβάσεις στην αφετηρία
  !  Β.
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 19
    ΓΡΑΨΕ 'Δώστε αριθμό ατόμων που αποβιβάστηκαν από τον ',i, 'σταθμό '
    Διάβασε ΑΠΟΒ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ! Γ.
  Πλήθος <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 19
    Πλήθος <-- Πλήθος + (ΕΠΙΒ[i] - ΑΠΟΒ[i])  
    ΑΕ[i] <-- Πλήθος
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ! Δ.
  μέγιστο <-- ΑΕ[1]     ! Έστω ότι ο 1ος σταθμός έχει τους περισσότερους επιβάτες
  μεγ_σταθμός <-- 1     ! Θέση μεγίστου στον πίνακα
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 19
    ΑΝ ΑΕ[i] &gt μέγιστο ΤΟΤΕ
      μέγιστο <-- ΑΕ[i]
      μεγ_σταθμός <-- i
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Σταθμός με τους περισσότερους επιβάτες: ', μεγ_σταθμός
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Share This