Επιλογή Σελίδας

Σε ένα πάρκινγκ η χρέωση γίνεται κλιμακωτά, όπως φαίνεται στον παρακάτω πίνακα:

ΔΙΑΡΚΕΙΑ ΣΤΑΘΜΕΥΣΗΣ ΚΟΣΤΟΣ ΑΝΑ ΩΡΑ
Μέχρι και 3 ώρες 2
Πάνω από 3 έως και 5 ώρες 1,5
Πάνω από 5 ώρες 1,3

Ι.   Να κατασκευάσετε πρόγραμμα το οποίο:

α) περιλαμβάνει τμήμα δηλώσεων.

Μονάδες 2

 

β)   για κάθε αυτοκίνητο που στάθμευσε στο πάρκινγκ:

i. διαβάζει τον αριθμό κυκλοφορίας μέχρι να δοθεί το 0. Να θεωρήσετε ότι ο αριθμός κυκλοφορίας μπορεί να περιέχει τόσο γράμματα όσο και αριθμούς.

Μονάδες 2

ii. διαβάζει τη διάρκεια στάθμευσης σε ώρες και τη δέχεται μόνο εφ’ όσον είναι μεγαλύτερη από το 0.

Μονάδες 3

iii. καλεί υποπρόγραμμα για τον υπολογισμό του ποσού που πρέπει να πληρώσει ο κάτοχός του.

Μονάδες 2

iv. εμφανίζει τον αριθμό κυκλοφορίας και το ποσό που αναλογεί.

Μονάδες 2

γ)   εμφανίζει το πλήθος των αυτοκινήτων που έμειναν στο πάρκινγκ μέχρι και δύο ώρες.

Μονάδες 4

ΙΙ.  Να κατασκευάσετε το υποπρόγραμμα που καλείται στο ερώτημα β) iii.

Μονάδες 5

ΛΥΣΗ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ_2006_ΕΠΑΝ_ΗΜΕΡ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΩΡΕΣ, ΠΛΗΘΟΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ
  ΧΑΡΑΚΤΗΡΕΣ:ΑΚ
ΑΡΧΗ
  ΠΛΗΘΟΣ <-- 0
  ΔΙΑΒΑΣΕ ΑΚ
  ΟΣΟ ΑΚ <> '0' ΕΠΑΝΑΛΑΒΕ
    ! Έλεγχος Εγκρυρότητας
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΩΡΕΣ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΩΡΕΣ>0
    ΠΟΣΟ <-- ΥΠΟΛ_ΧΡΕΩΣΗΣ(ΩΡΕΣ)
    ΓΡΑΨΕ ΑΚ, 'ΧΡΕΩΣΗ ', ΠΟΣΟ
    ΑΝ ΩΡΕΣ <= 2 ΤΟΤΕ
      ΠΛΗΘΟΣ <-- ΠΛΗΘΟΣ + 1
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΑΚ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'ΠΛΗΘΟΣ ΙΧ ΜΕ ΠΑΡΑΜΟΝΗ ΜΕΧΡΙ ΚΑΙ 2 ΩΡΕΣ ', ΠΛΗΘΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΥΠΟΛ_ΧΡΕΩΣΗΣ(ΩΡ): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΩΡ, ΧΡΕΩΣΗ
ΑΡΧΗ   
  ΑΝ ΩΡ <= 3 ΤΟΤΕ
    ΧΡΕΩΣΗ <-- 2
  ΑΛΛΙΩΣ_ΑΝ ΩΡ <= 5 ΤΟΤΕ
    ΧΡΕΩΣΗ <-- 3*2 + (ΩΡ-3) * 1.5
  ΑΛΛΙΩΣ
    ΧΡΕΩΣΗ <-- 3*2 + 2*1.5 + (ΩΡ-5) * 1.3
  ΤΕΛΟΣ_ΑΝ
  ΥΠΟΛ_ΧΡΕΩΣΗΣ <-- ΧΡΕΩΣΗ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τα θέματα σε pdf, 2006, Επαναληπτικές, Ημερήσια

Share This